summaryrefslogtreecommitdiff
path: root/net-analyzer/zmap/zmap-4.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-19 00:09:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-19 00:09:54 +0100
commite8df704cf9b5e9e517317b8912377c0a8ca0d11e (patch)
treeab3f43045fb1d37471f8217c8547d2120bb3d1da /net-analyzer/zmap/zmap-4.1.1.ebuild
parentccaccfe4f1da8c11d9fa110f6e4eb847358769d7 (diff)
gentoo auto-resync : 19:06:2024 - 00:09:54
Diffstat (limited to 'net-analyzer/zmap/zmap-4.1.1.ebuild')
-rw-r--r--net-analyzer/zmap/zmap-4.1.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/zmap/zmap-4.1.1.ebuild b/net-analyzer/zmap/zmap-4.1.1.ebuild
new file mode 100644
index 000000000000..2ffbd683d165
--- /dev/null
+++ b/net-analyzer/zmap/zmap-4.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake fcaps
+
+DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
+HOMEPAGE="https://zmap.io/"
+SRC_URI="https://github.com/zmap/zmap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="mongo redis"
+
+RDEPEND="
+ dev-libs/gmp:=
+ dev-libs/judy
+ dev-util/gengetopt
+ net-libs/libpcap
+ dev-libs/json-c:=
+ redis? ( dev-libs/hiredis:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/lex
+ dev-util/gengetopt
+ dev-util/byacc
+ virtual/pkgconfig
+"
+
+FILECAPS=( cap_net_raw=ep usr/sbin/zmap )
+
+src_prepare() {
+ sed \
+ -e '/ggo/s:CMAKE_CURRENT_SOURCE_DIR}:CMAKE_BINARY_DIR}/src:g' \
+ -i src/CMakeLists.txt || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEVELOPMENT=OFF
+ -DWITH_WERROR=OFF
+ )
+
+ cmake_src_configure
+}