summaryrefslogtreecommitdiff
path: root/net-analyzer/zmap/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-19 00:09:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-19 00:09:54 +0100
commite8df704cf9b5e9e517317b8912377c0a8ca0d11e (patch)
treeab3f43045fb1d37471f8217c8547d2120bb3d1da /net-analyzer/zmap/files
parentccaccfe4f1da8c11d9fa110f6e4eb847358769d7 (diff)
gentoo auto-resync : 19:06:2024 - 00:09:54
Diffstat (limited to 'net-analyzer/zmap/files')
-rw-r--r--net-analyzer/zmap/files/zmap-2.1.1-json-c.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/zmap/files/zmap-2.1.1-json-c.patch b/net-analyzer/zmap/files/zmap-2.1.1-json-c.patch
new file mode 100644
index 000000000000..78a80b801218
--- /dev/null
+++ b/net-analyzer/zmap/files/zmap-2.1.1-json-c.patch
@@ -0,0 +1,31 @@
+From 5473b6a907ff47e813e8ac3509a0f63d1253023b Mon Sep 17 00:00:00 2001
+From: Martin Milata <martin@martinmilata.cz>
+Date: Wed, 1 Jul 2020 16:47:18 +0200
+Subject: [PATCH] Fix build against json-c-0.14 (#609)
+
+The new pkgconfig file contains two include directories:
+
+ Cflags: -I${includedir} -I${includedir}/json-c
+
+Apparently pkg_check_modules returns them as a semicolon-separated
+string ("CMake list"), which causes the build to fail when appended
+directly to CMAKE_C_FLAGS.
+
+Origin: backport, https://github.com/zmap/zmap/commit/5473b6a907ff47e813e8ac3509a0f63d1253023b
+Applied-Upstream: 3.0
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: zmap-2.1.1/CMakeLists.txt
+===================================================================
+--- zmap-2.1.1.orig/CMakeLists.txt 2024-01-23 15:29:55.436869754 -0500
++++ zmap-2.1.1/CMakeLists.txt 2024-01-23 15:30:32.505023070 -0500
+@@ -72,6 +72,7 @@
+ endif()
+
+ add_definitions("-DJSON")
++ string(REPLACE ";" " " JSON_CFLAGS "${JSON_CFLAGS}")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${JSON_CFLAGS}")
+ endif()
+