summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /net-analyzer/wireshark/files
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'net-analyzer/wireshark/files')
-rw-r--r--net-analyzer/wireshark/files/wireshark-2.6.1-Qt-5.11.patch54
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch34
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-qtsvg.patch29
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch11
4 files changed, 128 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-2.6.1-Qt-5.11.patch b/net-analyzer/wireshark/files/wireshark-2.6.1-Qt-5.11.patch
new file mode 100644
index 000000000000..c8d8bb9ce9c2
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-2.6.1-Qt-5.11.patch
@@ -0,0 +1,54 @@
+From b8e8aa87f43c12ad564426b3359f593305cd45a1 Mon Sep 17 00:00:00 2001
+From: Roland Knall <rknall@gmail.com>
+Date: Wed, 25 Apr 2018 10:28:30 +0200
+Subject: [PATCH] Qt: Fix various missing header includes
+
+Qt 5.11 seems to have changed the include dependencies, so adding those, that are missing
+
+Change-Id: I2b0482f7554467d6981be65bfd3fea1a3e118976
+Reviewed-on: https://code.wireshark.org/review/27145
+Petri-Dish: Roland Knall <rknall@gmail.com>
+Tested-by: Petri Dish Buildbot
+Reviewed-by: Roland Knall <rknall@gmail.com>
+---
+ ui/qt/packet_format_group_box.cpp | 1 +
+ ui/qt/time_shift_dialog.cpp | 1 +
+ ui/qt/wireless_frame.cpp | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/ui/qt/packet_format_group_box.cpp b/ui/qt/packet_format_group_box.cpp
+index a80a71aaaddfce2798ececcbb27a4d9e75382c1b..3c0fff28aa4cd91d344f2e70db1e66123bc17f41 100644
+--- a/ui/qt/packet_format_group_box.cpp
++++ b/ui/qt/packet_format_group_box.cpp
+@@ -10,6 +10,7 @@
+ #include <ui_packet_format_group_box.h>
+
+ #include <QStyle>
++#include <QStyleOption>
+
+ PacketFormatGroupBox::PacketFormatGroupBox(QWidget *parent) :
+ QGroupBox(parent),
+diff --git a/ui/qt/time_shift_dialog.cpp b/ui/qt/time_shift_dialog.cpp
+index 93882c09a377a5630e8bb09b4e80d7f6a84f7293..8460db2e966a0f572478de7430b8b63f4473dd16 100644
+--- a/ui/qt/time_shift_dialog.cpp
++++ b/ui/qt/time_shift_dialog.cpp
+@@ -14,6 +14,7 @@
+ #include <ui/time_shift.h>
+ #include <ui/qt/utils/tango_colors.h>
+
++#include <QStyleOption>
+
+ TimeShiftDialog::TimeShiftDialog(QWidget *parent, capture_file *cf) :
+ QDialog(parent),
+diff --git a/ui/qt/wireless_frame.cpp b/ui/qt/wireless_frame.cpp
+index bd9076abcf4a5d7b6fd73d2bc0b63b4fff8c256a..46fb2dd2f3054f66380239106fb2e27058196447 100644
+--- a/ui/qt/wireless_frame.cpp
++++ b/ui/qt/wireless_frame.cpp
+@@ -23,6 +23,7 @@
+ #include <wsutil/frequency-utils.h>
+
+ #include <QProcess>
++#include <QAbstractItemView>
+
+ // To do:
+ // - Disable or hide invalid channel types.
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch b/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
new file mode 100644
index 000000000000..8ceb3ba54882
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-androiddump-wsutil.patch
@@ -0,0 +1,34 @@
+--- a/extcap/CMakeLists.txt
++++ b/extcap/CMakeLists.txt
+@@ -68,6 +68,8 @@
+ if(HAVE_LIBPCAP)
+ set(androiddump_LIBS
+ ui
++ wiretap
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${PCAP_LIBRARIES}
+ )
+@@ -78,6 +80,7 @@
+ set(androiddump_LIBS
+ ui
+ wiretap
++ wsutil
+ ${GLIB2_LIBRARIES}
+ ${ZLIB_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+@@ -89,7 +92,6 @@
+ )
+
+ add_executable(androiddump WIN32 ${androiddump_FILES})
+- # XXX Shouldn't we add wsutil to androiddump_LIBS instead?
+ set_extcap_executable_properties(androiddump)
+ target_link_libraries(androiddump ${androiddump_LIBS})
+ install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_DIR})
+@@ -212,4 +214,4 @@
+ ${androiddump_FILES}
+ ${sshdump_FILES}
+ ${ciscodump_FILES}
+-)
+\ No newline at end of file
++)
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-qtsvg.patch b/net-analyzer/wireshark/files/wireshark-99999999-qtsvg.patch
new file mode 100644
index 000000000000..4f151dbba21b
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-qtsvg.patch
@@ -0,0 +1,29 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -910,14 +910,12 @@
+ Qt5LinguistTools
+ Qt5Multimedia
+ Qt5PrintSupport
+- Qt5Svg
+ Qt5Widgets
+ )
+ set(Qt5Core_OPTIONS REQUIRED)
+ set(Qt5LinguistTools_OPTIONS REQUIRED)
+ set(Qt5Multimedia_OPTIONS REQUIRED)
+ set(Qt5PrintSupport_OPTIONS REQUIRED)
+- set(Qt5Svg_OPTIONS REQUIRED)
+ set(Qt5Widgets_OPTIONS REQUIRED)
+ if (APPLE)
+ set(PACKAGELIST ${PACKAGELIST} Qt5MacExtras)
+@@ -1187,11 +1185,6 @@
+ # That's the name autotools used
+ set(QT_MULTIMEDIA_LIB 1)
+ endif()
+- if(Qt5Svg_FOUND)
+- set (QT_LIBRARIES ${QT_LIBRARIES} ${Qt5Svg_LIBRARIES})
+- # That's the name autotools used
+- set(QT_SVG_LIB 1)
+- endif()
+ if(Qt5MacExtras_FOUND)
+ set (QT_LIBRARIES ${QT_LIBRARIES} ${Qt5MacExtras_LIBRARIES})
+ # That's the name autotools used
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch b/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch
new file mode 100644
index 000000000000..c0bfc3acd5a6
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-ui-needs-wiretap.patch
@@ -0,0 +1,11 @@
+--- a/ui/CMakeLists.txt
++++ b/ui/CMakeLists.txt
+@@ -76,6 +76,8 @@
+
+ add_library(ui STATIC ${UI_SRC})
+
++set(ui_LIBS wiretap)
++
+ set_target_properties(ui PROPERTIES
+ LINK_FLAGS "${WS_LINK_FLAGS}"
+ FOLDER "UI"