summaryrefslogtreecommitdiff
path: root/net-analyzer/wireshark/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/wireshark/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/wireshark/files')
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.99.8-qtchooser.patch10
-rw-r--r--net-analyzer/wireshark/files/wireshark-2.1.0-sse4_2-r1.patch21
-rw-r--r--net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch27
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-androiddump.patch10
4 files changed, 68 insertions, 0 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-1.99.8-qtchooser.patch b/net-analyzer/wireshark/files/wireshark-1.99.8-qtchooser.patch
new file mode 100644
index 000000000000..47459515ee79
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.99.8-qtchooser.patch
@@ -0,0 +1,10 @@
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -2149,7 +2149,6 @@
+ # -qt={version} argument, otherwise we look for particular
+ # tool versions using tool name suffixes.
+ #
+- AC_PATH_PROG(QTCHOOSER, qtchooser)
+ if test ! -z "$QTCHOOSER"; then
+ #
+ # We found qtchooser; we assume that means that
diff --git a/net-analyzer/wireshark/files/wireshark-2.1.0-sse4_2-r1.patch b/net-analyzer/wireshark/files/wireshark-2.1.0-sse4_2-r1.patch
new file mode 100644
index 000000000000..8efe5aff6c55
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-2.1.0-sse4_2-r1.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -818,6 +818,7 @@
+ AC_SUBST(PIE_CFLAGS)
+ AC_SUBST(PIE_LDFLAGS)
+
++AC_ARG_ENABLE(sse4_2,[ --enable-sse4_2 Support SSE4.2 (Streaming SIMD Extensions 4.2) instructions],[
+ WS_CFLAGS_saved="$WS_CFLAGS"
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-msse4.2, C)
+ if test "x$can_add_to_cflags" = "xyes"
+@@ -844,6 +845,10 @@
+ ac_sse4_2_flag=-xarch=sse4_2
+ fi
+ fi
++],[
++AC_MSG_RESULT(no)
++])
++
+ WS_CFLAGS="$WS_CFLAGS_saved"
+
+ if test "x$ac_sse4_2_flag" != x; then
diff --git a/net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch b/net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch
new file mode 100644
index 000000000000..e67ab21b6a8d
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-2.4-androiddump.patch
@@ -0,0 +1,27 @@
+--- a/extcap/androiddump.c
++++ b/extcap/androiddump.c
+@@ -363,13 +363,13 @@
+ pcap = pcap_open_dead_with_tstamp_precision(encap_ext, PACKET_LENGTH, PCAP_TSTAMP_PRECISION_NANO);
+ extcap_dumper.dumper.pcap = pcap_dump_open(pcap, fifo);
+ if (!extcap_dumper.dumper.pcap) {
+- g_warning("Can't open %s for saving packets: %s", pcap_geterr(pcap));
++ g_warning("Can't open %s for saving packets: %s", fifo, pcap_geterr(pcap));
+ pcap_close(pcap);
+ exit(EXIT_CODE_CANNOT_SAVE_LIBPCAP_DUMP);
+ }
+ extcap_dumper.encap = encap;
+ if (pcap_dump_flush(extcap_dumper.dumper.pcap) == -1) {
+- g_warning("Write to %s failed: %s", g_strerror(errno));
++ g_warning("Write to %s failed: %s", fifo, g_strerror(errno));
+ }
+ #else
+ int err = 0;
+@@ -416,7 +416,7 @@
+
+ pcap_dump((u_char *) extcap_dumper.dumper.pcap, &pcap_header, buffer);
+ if (pcap_dump_flush(extcap_dumper.dumper.pcap) == -1) {
+- g_warning("Write to %s failed: %s", g_strerror(errno));
++ g_warning("Write to %s failed: %s", fifo, g_strerror(errno));
+ }
+ #else
+ int err = 0;
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-androiddump.patch b/net-analyzer/wireshark/files/wireshark-99999999-androiddump.patch
new file mode 100644
index 000000000000..124a9b8b00be
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-androiddump.patch
@@ -0,0 +1,10 @@
+--- a/extcap/Makefile.am
++++ b/extcap/Makefile.am
+@@ -49,6 +49,7 @@
+ androiddump_LDADD = \
+ ../wiretap/libwiretap.la \
+ ../wsutil/libwsutil.la \
++ @PCAP_LIBS@ \
+ @GLIB_LIBS@
+
+ if ENABLE_STATIC