summaryrefslogtreecommitdiff
path: root/net-analyzer/wapiti/wapiti-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 03:06:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 03:06:27 +0000
commitc8273339188289fe8571e5a8cb9e00e59a46aaaf (patch)
tree793a97e856b00e8c923cb6b505ea175f89b35cf2 /net-analyzer/wapiti/wapiti-9999.ebuild
parent60f657b5e6155f26601c7def7baa11cee72246d0 (diff)
gentoo auto-resync : 02:02:2023 - 03:06:27
Diffstat (limited to 'net-analyzer/wapiti/wapiti-9999.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-analyzer/wapiti/wapiti-9999.ebuild b/net-analyzer/wapiti/wapiti-9999.ebuild
index 979d31139bd6..462342ee254f 100644
--- a/net-analyzer/wapiti/wapiti-9999.ebuild
+++ b/net-analyzer/wapiti/wapiti-9999.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE='xml(+)'
inherit distutils-r1 git-r3
@@ -17,6 +18,7 @@ SLOT="0"
KEYWORDS=""
# Requires httpx-ntlm (to package)
#IUSE="ntlm"
+IUSE="test"
# httpx requires brotli and socks, so depending on
# dev-python/socksio and dev-python/brotlicffi
@@ -30,7 +32,7 @@ RDEPEND="dev-python/beautifulsoup4[${PYTHON_USEDEP}]
dev-python/tld[${PYTHON_USEDEP}]
dev-python/yaswfp[${PYTHON_USEDEP}]"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
# Tests also require unpackaged respx
BDEPEND+=" test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]