summaryrefslogtreecommitdiff
path: root/net-analyzer/wapiti/wapiti-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-analyzer/wapiti/wapiti-9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-analyzer/wapiti/wapiti-9999.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-9999.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/net-analyzer/wapiti/wapiti-9999.ebuild b/net-analyzer/wapiti/wapiti-9999.ebuild
index be4f6180daec..14fd985c3532 100644
--- a/net-analyzer/wapiti/wapiti-9999.ebuild
+++ b/net-analyzer/wapiti/wapiti-9999.ebuild
@@ -1,24 +1,28 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{5,6} )
PYTHON_REQ_USE='xml'
-ESVN_REPO_URI="https://svn.code.sf.net/p/wapiti/code/trunk/"
-inherit distutils-r1 subversion
+inherit distutils-r1 git-r3
DESCRIPTION="Web-application vulnerability scanner"
HOMEPAGE="http://wapiti.sourceforge.net/"
-SRC_URI=""
+EGIT_REPO_URI="https://git.code.sf.net/p/wapiti/git wapiti-git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="kerberos ntlm"
+IUSE="kerberos ntlm test"
-DEPEND=""
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
@@ -27,3 +31,8 @@ RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/yaswfp[${PYTHON_USEDEP}]
kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e 's/"pytest-runner"//' -i setup.py || die
+ distutils-r1_python_prepare_all
+}