summaryrefslogtreecommitdiff
path: root/net-analyzer/vnstat/vnstat-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-analyzer/vnstat/vnstat-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-analyzer/vnstat/vnstat-9999.ebuild')
-rw-r--r--net-analyzer/vnstat/vnstat-9999.ebuild19
1 files changed, 17 insertions, 2 deletions
diff --git a/net-analyzer/vnstat/vnstat-9999.ebuild b/net-analyzer/vnstat/vnstat-9999.ebuild
index ff0d5392bc37..ef79532e70ff 100644
--- a/net-analyzer/vnstat/vnstat-9999.ebuild
+++ b/net-analyzer/vnstat/vnstat-9999.ebuild
@@ -3,11 +3,25 @@
EAPI=7
-inherit git-r3 systemd user tmpfiles
+inherit systemd user tmpfiles
DESCRIPTION="Console-based network traffic monitor that keeps statistics of network usage"
HOMEPAGE="https://humdi.net/vnstat/"
-EGIT_REPO_URI="https://github.com/vergoh/vnstat"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/vergoh/vnstat"
+ inherit git-r3
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/teemutoivola.asc
+ inherit verify-sig
+
+ SRC_URI="https://humdi.net/vnstat/${P}.tar.gz"
+ SRC_URI+=" verify-sig? ( https://humdi.net/vnstat/${P}.tar.gz.asc )"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+ BDEPEND="verify-sig? ( app-crypt/openpgp-keys-teemutoivola )"
+fi
LICENSE="GPL-2"
SLOT="0"
@@ -60,6 +74,7 @@ src_install() {
newtmpfiles "${FILESDIR}"/vnstatd.tmpfile vnstatd.conf
use gd && doman man/vnstati.1
+
doman man/vnstat.1 man/vnstatd.1
newdoc INSTALL.md README.setup