summaryrefslogtreecommitdiff
path: root/net-analyzer/traceproto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-analyzer/traceproto
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-analyzer/traceproto')
-rw-r--r--net-analyzer/traceproto/Manifest3
-rw-r--r--net-analyzer/traceproto/files/traceproto-1.1.2_beta1-fno-common.patch122
-rw-r--r--net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild20
3 files changed, 137 insertions, 8 deletions
diff --git a/net-analyzer/traceproto/Manifest b/net-analyzer/traceproto/Manifest
index 5fdc371cbe3f..c23d62a1a62d 100644
--- a/net-analyzer/traceproto/Manifest
+++ b/net-analyzer/traceproto/Manifest
@@ -1,4 +1,5 @@
+AUX traceproto-1.1.2_beta1-fno-common.patch 2575 BLAKE2B 307b1480fa0a1c13e3ed0b3903909399fa742061d02ac621ec667ca0579ccea8d6462beb01e4a3a57e0fd83fc9f2888aee5c8a537e4163da956d9f23d91304c8 SHA512 70537e2ddcb7be3c55144ba7966ff34fd8c98a74ae4eddf285f90d909f6e98816915f5b91ce8608ba98468bd536e395fa61c0758f94229f310365e031e521d68
AUX traceproto-1.1.2_beta1-tinfo.patch 804 BLAKE2B 5cb11304467e6a29a398f952d7526378243b402c25d7e76b6123b60b5bdbcc5cdf9f574b428e7f2e8cde3f54afa5326a0c92a5fa6f55b259388b2279495bb245 SHA512 d1c6653637b2d5ed812bd3999ae3f5456fb36621b7d2ed3c8502b9a25abd6303b1b3fff268a557ad288b35a9075079376f533f4a76dcada64d92b85c2d351b3f
DIST traceproto-1.1.2beta1.tar.gz 192288 BLAKE2B 6b122fe84a3a2581792256c6be7a5ccdb2b42da923ff70fc2ec07956d2a95fdf882e381954b0b6e5de27e06bc713a40a9abb5bbac52ac796f34b6ec337790843 SHA512 e7c99fd0ccc6a8e21901d538b9a05ff26807afdd749ab53e958722ad7fa54c27545c95e4bc390a6a06130e7a123f8fa4c7f794ca7b25180a4d3ca5044d1e7364
-EBUILD traceproto-1.1.2_beta1.ebuild 758 BLAKE2B 655d1f682d9d8a28822655ca7b82823e9d4fa370183a874aaefb7d8a13ecc30f50f30d0fbb3ea322ceeec6ffb3a723adea9c81657ddc89faf6861ca187dd11d0 SHA512 d8f78fa49625affccaaa0ed7246318d6dc6ffd325b555a1069b55705927f2a9ef1821f0bb6b5a07e90aaa73740f3307b06c3cdeb11429728789bc9b798c9e796
+EBUILD traceproto-1.1.2_beta1.ebuild 813 BLAKE2B b3aeb0f9a04d250e7160d6bfb63cfba0f8b451bc4937c4d18b7b6cad1e4aa12ca432989ea308f8c918f31002da3e08c108a1c126db17ee537d450746811ab33d SHA512 1522bc703686b7f47b94ee7cc29c2c977094854dfc7aa75daae6fed7ffdff6f1905422c5f2ddfacd3993628d66221f578e018b9daa76a6de3dc23ca7708ac0ea
MISC metadata.xml 360 BLAKE2B 0f362693cec18bfafae2e7f86116101904e9fb65722bd08c1879efb4d9e862e6db1368898ccbd1fee868ee9fb52ecea5f8c3e20e141474406a45cca2c6911fcb SHA512 09c1bdd4747222c72f8db8e0486a93b67ece13643ef4532175af88ae7a550a44c5a7533b9926c4898a6aefaff069c0d43befd781430927a199489901553456e6
diff --git a/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-fno-common.patch b/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-fno-common.patch
new file mode 100644
index 000000000000..8d95517ab27c
--- /dev/null
+++ b/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-fno-common.patch
@@ -0,0 +1,122 @@
+--- a/tp_as.c
++++ b/tp_as.c
+@@ -50,6 +50,7 @@ static char * ra_service;
+ static struct hostent * ra_hostent;
+ static struct servent * ra_servent;
+
++char as_string[1024];
+
+ int setup_as ( void )
+ {
+--- a/tp_as.h
++++ b/tp_as.h
+@@ -33,7 +33,7 @@
+ #ifndef TP_AS_H
+ #define TP_AS_H 1
+
+-char as_string[1024];
++extern char as_string[1024];
+
+ /*! Initialisation function for AS lookups; returns 0 iff successful. */
+ int setup_as(void);
+--- a/tp_miscfunc.c
++++ b/tp_miscfunc.c
+@@ -52,6 +52,8 @@
+ #include <dmalloc.h>
+ #endif /* HAVE_LIBDMALLOC */
+
++struct cleanup tixe_cleanup;
++
+ /*
+ * take a comma separated list (sans spaces) and give them a miss
+ * (ie don't send probes with the ttl set to these numbers)
+--- a/tp_miscfunc.h
++++ b/tp_miscfunc.h
+@@ -32,7 +32,8 @@ struct cleanup {
+ unsigned int libnet_cleanup : 1;
+ unsigned int pcap_cleanup : 1;
+ unsigned int addrinfo_cleanup : 1;
+-} tixe_cleanup;
++};
++extern struct cleanup tixe_cleanup;
+
+ int parse_skips ( char * );
+
+--- a/traceproto.c
++++ b/traceproto.c
+@@ -55,6 +55,12 @@
+ #include <dmalloc.h>
+ #endif /* HAVE_LIBDMALLOC */
+
++struct tp_align_ref tp_align_freelist;
++struct behavior behavior;
++struct packet packet;
++struct state state;
++struct debug debug;
++
+ int main( int argc, char * argv[] )
+ {
+
+--- a/traceproto.h
++++ b/traceproto.h
+@@ -104,9 +104,10 @@ enum tp_tstamps {
+ struct tp_align_ref {
+ struct tp_align_ref * next;
+ u_char * ref;
+-} tp_align_freelist;
++};
++extern struct tp_align_ref tp_align_freelist;
+
+-struct {
++struct behavior {
+ unsigned int continuous : 1;
+ unsigned int continuous_accounting : 1;
+ unsigned int do_skip : 1;
+@@ -148,9 +149,10 @@ struct {
+ char timestamp_str [ TP_TIMESTAMP_LEN ];
+ char timestamp_style;
+ struct addrinfo hint;
+-} behavior;
++};
++extern struct behavior behavior;
+
+-struct {
++struct packet {
+ int dst_port;
+ int src_port;
+ int protocol_number;
+@@ -161,9 +163,10 @@ struct {
+ long packed_src;
+ unsigned short frag_bit;
+ unsigned short ip_id;
+-} packet;
++};
++extern struct packet packet;
+
+-struct {
++struct state {
+ char * prog;
+ unsigned int account_hops;
+ struct hop_record {
+@@ -208,9 +211,10 @@ struct {
+ unsigned int low_ttl;
+ unsigned int incr_error : 1;
+ unsigned int target_response : 1;
+-} state;
++};
++extern struct state state;
+
+-struct {
++struct debug {
+ unsigned int loop : 1;
+ unsigned int interface : 1;
+ unsigned int send_buf : 1;
+@@ -219,6 +223,7 @@ struct {
+ unsigned int timestamp : 1;
+ unsigned int as_lookup : 1;
+ unsigned int memory : 1;
+-} debug;
++};
++extern struct debug debug;
+
+ #endif /* TRACEPROTO_H */
diff --git a/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
index 15e52604060b..28f0ddbe591e 100644
--- a/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
+++ b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools
+EAPI=7
+
+inherit autotools
MY_PV=${PV/_/}
@@ -18,11 +19,11 @@ IUSE="debug"
RDEPEND="
net-libs/libnet:1.1
net-libs/libpcap
- sys-libs/ncurses
+ sys-libs/ncurses:0=
debug? ( dev-libs/dmalloc )
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
app-doc/doxygen[dot]
virtual/pkgconfig
"
@@ -31,8 +32,13 @@ S=${WORKDIR}/${PN}-${MY_PV}
DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}/${P}-tinfo.patch"
+ "${FILESDIR}/${P}-fno-common.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-tinfo.patch
+ default
eautoreconf
}