summaryrefslogtreecommitdiff
path: root/net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild')
-rw-r--r--net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild b/net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild
new file mode 100644
index 000000000000..191ed447f475
--- /dev/null
+++ b/net-analyzer/thcrut/thcrut-1.2.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Network discovery and fingerprinting tool"
+HOMEPAGE="http://www.thc.org/thc-rut/"
+SRC_URI="http://www.thc.org/thc-rut/${P}.tar.gz"
+
+LICENSE="free-noncomm PCRE GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+ dev-libs/libpcre
+ net-libs/libnet:1.0
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=( ChangeLog FAQ README TODO thcrutlogo.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-libnet.patch
+)
+
+src_prepare() {
+ rm -r Libnet-1.0.2a pcre-3.9 || die
+ default
+ eautoreconf
+}