summaryrefslogtreecommitdiff
path: root/net-analyzer/thcrut/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/thcrut/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/thcrut/files')
-rw-r--r--net-analyzer/thcrut/files/thcrut-1.2.5-configure.patch42
-rw-r--r--net-analyzer/thcrut/files/thcrut-1.2.5-libnet.patch65
2 files changed, 107 insertions, 0 deletions
diff --git a/net-analyzer/thcrut/files/thcrut-1.2.5-configure.patch b/net-analyzer/thcrut/files/thcrut-1.2.5-configure.patch
new file mode 100644
index 000000000000..daa069e22afd
--- /dev/null
+++ b/net-analyzer/thcrut/files/thcrut-1.2.5-configure.patch
@@ -0,0 +1,42 @@
+--- a/configure.in
++++ b/configure.in
+@@ -153,10 +153,8 @@
+ dnl libnet_init_packet only available in < libnet-1.1.x
+ dnl AC_CHECK_LIB(net, libnet_init_packet,, AC_MSG_ERROR(We need libnet.
+ dnl Get libnet from http://www.packetfactory.net or try --with-[[libs,includes]]=DIR))
+-AC_CHECK_LIB(net, libnet_init_packet, [NET=yes], [NET=no])
++AC_CHECK_LIB(net-1.0, libnet_init_packet, [NET=yes], [NET=no])
+ if test x"$NET" = x"no" -o x"$DIST" = x"yes"; then
+- AC_CONFIG_SUBDIRS(Libnet-1.0.2a)
+- THCRUT_SUBDIRS="$THCRUT_SUBDIRS Libnet-1.0.2a"
+ CPPFLAGS="-I../Libnet-1.0.2a/include ${CPPFLAGS}"
+ LDFLAGS="-L../Libnet-1.0.2a/src ${LDFLAGS}"
+ PRG_LIBNET_CONFIG_CFLAGS="../Libnet-1.0.2a/libnet-config --cflags --defines | tr '\n' ' '"
+@@ -164,14 +162,12 @@
+ dnl CFLAGS="`${srcdir}/Libnet-1.0.2a/libnet-config --cflags --defines | tr '\n' ' '` $CFLAGS"
+ dnl LIBS="`${srcdir}/Libnet-1.0.2a/libnet-config --libs` $LIBS"
+ else
+- CFLAGS="`libnet-config --cflags --defines | tr '\n' ' '` $CFLAGS"
+- LIBS="`libnet-config --libs` $LIBS"
++ CFLAGS="`libnet-1.0-config --cflags --defines | tr '\n' ' '` $CFLAGS"
++ LIBS="`libnet-1.0-config --libs` $LIBS"
+ fi
+
+ AC_CHECK_LIB(pcre, pcre_compile, [PCRE=yes], [PCRE=no])
+ if test x"$PCRE" = x"no" -o x"$DIST" = x"yes"; then
+- AC_CONFIG_SUBDIRS(pcre-3.9)
+- THCRUT_SUBDIRS="$THCRUT_SUBDIRS pcre-3.9"
+ CPPFLAGS="-I../pcre-3.9 ${CPPFLAGS}"
+ LDFLAGS="-L../pcre-3.9 ${LDFLAGS}"
+ PRG_PCRE_CONFIG_CFLAGS="../pcre-3.9/pcre-config --cflags"
+@@ -199,8 +195,8 @@
+ AC_OUTPUT(Makefile src/Makefile)
+
+ dnl Just to show the correct values...
+-CFLAGS="`${srcdir}/pcre-3.9/pcre-config --cflags` `${srcdir}/Libnet-1.0.2a/libnet-config --cflags --defines | tr '\n' ' '` $CFLAGS"
+-LIBS="`${srcdir}/pcre-3.9/pcre-config --libs` `${srcdir}/Libnet-1.0.2a/libnet-config --libs` $LIBS"
++CFLAGS="`${srcdir}/pcre-3.9/pcre-config --cflags` `libnet-config --cflags --defines | tr '\n' ' '` $CFLAGS"
++LIBS="`${srcdir}/pcre-3.9/pcre-config --libs` `libnet-config --libs` $LIBS"
+
+ echo "THCrut has been configured with the following options:"
+ echo " User binaries: $B"
diff --git a/net-analyzer/thcrut/files/thcrut-1.2.5-libnet.patch b/net-analyzer/thcrut/files/thcrut-1.2.5-libnet.patch
new file mode 100644
index 000000000000..87488c8c5196
--- /dev/null
+++ b/net-analyzer/thcrut/files/thcrut-1.2.5-libnet.patch
@@ -0,0 +1,65 @@
+--- a/src/arp_main.c
++++ b/src/arp_main.c
+@@ -18 +18 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/arpg.c
++++ b/src/arpg.c
+@@ -12 +12 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/dhcp_main.c
++++ b/src/dhcp_main.c
+@@ -14 +14 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/discover_dispatch.c
++++ b/src/discover_dispatch.c
+@@ -10 +10 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/discover_main.c
++++ b/src/discover_main.c
+@@ -8 +8 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/fp.h
++++ b/src/fp.h
+@@ -10 +10 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/icmp_main.c
++++ b/src/icmp_main.c
+@@ -14 +14 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/network_raw.c
++++ b/src/network_raw.c
+@@ -10 +10 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/packets.c
++++ b/src/packets.c
+@@ -6 +6 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/thcrut.c
++++ b/src/thcrut.c
+@@ -87 +87 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/thcrut.h
++++ b/src/thcrut.h
+@@ -7 +7 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/thcrut_libnet.c
++++ b/src/thcrut_libnet.c
+@@ -5 +5 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>
+--- a/src/thcrut_libnet.h
++++ b/src/thcrut_libnet.h
+@@ -5 +5 @@
+-#include <libnet.h>
++#include <libnet-1.0.h>