summaryrefslogtreecommitdiff
path: root/net-analyzer/thc-ipv6/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/thc-ipv6/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/thc-ipv6/files')
-rw-r--r--net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch24
-rw-r--r--net-analyzer/thc-ipv6/files/thc-ipv6-3.0-Makefile.patch11
2 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch b/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch
new file mode 100644
index 000000000000..d7b42147ae1e
--- /dev/null
+++ b/net-analyzer/thc-ipv6/files/thc-ipv6-2.1-Makefile.patch
@@ -0,0 +1,24 @@
+--- thc-ipv6-2.1/Makefile
++++ thc-ipv6-2.1/Makefile
+@@ -4,7 +4,7 @@
+
+ CC=gcc
+ #CFLAGS=-g
+-CFLAGS=-O2
++CFLAGS?=-O2
+ CFLAGS+=$(if $(HAVE_SSL),-D_HAVE_SSL,)
+ LDFLAGS+=-lpcap $(if $(HAVE_SSL),-lssl -lcrypto,)
+ PROGRAMS=parasite6 dos-new-ip6 detect-new-ip6 fake_router6 fake_advertise6 fake_solicitate6 fake_mld6 fake_mld26 fake_mldrouter6 flood_mldrouter6 fake_mipv6 redir6 smurf6 alive6 toobig6 rsmurf6 implementation6 implementation6d sendpees6 sendpeesmp6 randicmp6 fuzz_ip6 flood_mld6 flood_mld26 flood_router6 flood_advertise6 flood_solicitate6 trace6 exploit6 denial6 fake_dhcps6 flood_dhcpc6 fake_dns6d fragmentation6 kill_router6 fake_dnsupdate6 ndpexhaust6 detect_sniffer6 dump_router6 fake_router26 flood_router26 passive_discovery6 dnsrevenum6 inverse_lookup6 node_query6 address6 covert_send6 covert_send6d inject_alive6 firewall6 ndpexhaust26 fake_pim6
+@@ -17,10 +17,10 @@
+ all: $(LIBS) $(PROGRAMS) dnssecwalk dnsdict6 thcping6
+
+ dnssecwalk: dnssecwalk.c
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
+
+ dnsdict6: dnsdict6.c
+- $(CC) $(CFLAGS) -o $@ $^ -lpthread -lresolv
++ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -lpthread -lresolv
+
+ thcping6: thcping6.c $(LIBS)
+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -lrt
diff --git a/net-analyzer/thc-ipv6/files/thc-ipv6-3.0-Makefile.patch b/net-analyzer/thc-ipv6/files/thc-ipv6-3.0-Makefile.patch
new file mode 100644
index 000000000000..43b72eeb9069
--- /dev/null
+++ b/net-analyzer/thc-ipv6/files/thc-ipv6-3.0-Makefile.patch
@@ -0,0 +1,11 @@
+diff -Nuar thc-ipv6-3.0.orig/Makefile thc-ipv6-3.0/Makefile
+--- thc-ipv6-3.0.orig/Makefile 2015-10-13 20:17:34.000000000 -0700
++++ thc-ipv6-3.0/Makefile 2016-11-18 15:57:57.577946828 -0800
+@@ -19,5 +19,5 @@
+ dnssecwalk: dnssecwalk.c
+- $(CC) $(CFLAGS) $(STATIC) -o $@ $^
++ $(CC) $(CFLAGS) $(STATIC) -o $@ $^ $(LDFLAGS)
+
+ dnsdict6: dnsdict6.c
+- $(CC) $(CFLAGS) $(STATIC) -o $@ $^ -lpthread -lresolv
++ $(CC) $(CFLAGS) $(STATIC) -o $@ $^ $(LDFLAGS) -lpthread -lresolv