summaryrefslogtreecommitdiff
path: root/net-analyzer/tcptrack/tcptrack-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/tcptrack/tcptrack-1.4.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/tcptrack/tcptrack-1.4.2.ebuild')
-rw-r--r--net-analyzer/tcptrack/tcptrack-1.4.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/tcptrack/tcptrack-1.4.2.ebuild b/net-analyzer/tcptrack/tcptrack-1.4.2.ebuild
new file mode 100644
index 000000000000..235ac5dff8d2
--- /dev/null
+++ b/net-analyzer/tcptrack/tcptrack-1.4.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Passive per-connection tcp bandwidth monitor"
+HOMEPAGE="http://www.rhythm.cx/~steve/devel/tcptrack/"
+SRC_URI="http://www.rhythm.cx/~steve/devel/tcptrack/release/${PV}/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ sed -i src/Makefile.am -e 's| -Werror||g' || die
+ eautoreconf
+}