summaryrefslogtreecommitdiff
path: root/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
commite937ca8df21d3186f65edc11c872706c80eb8a61 (patch)
tree6758813cd0a8bd1da09045a9171ff389b1b39718 /net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild
parent1b5d79237a144dcb8753c783941843d879a906e2 (diff)
gentoo auto-resync : 20:03:2024 - 13:00:14
Diffstat (limited to 'net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild')
-rw-r--r--net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild b/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild
index 6757aed273ce..5453f2914699 100644
--- a/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild
+++ b/net-analyzer/tcptrace/tcptrace-6.6.7_p6-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="A Tool for analyzing network packet dumps"
HOMEPAGE="http://www.tcptrace.org/"
@@ -38,6 +38,19 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861260
+ #
+ # Upstream site no longer exists.
+ #
+ # Do not trust with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_compile() {
emake CCOPT="${CFLAGS}"
}