summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpslice/tcpslice-1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /net-analyzer/tcpslice/tcpslice-1.5.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'net-analyzer/tcpslice/tcpslice-1.5.ebuild')
-rw-r--r--net-analyzer/tcpslice/tcpslice-1.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-analyzer/tcpslice/tcpslice-1.5.ebuild b/net-analyzer/tcpslice/tcpslice-1.5.ebuild
new file mode 100644
index 000000000000..3a527c4395da
--- /dev/null
+++ b/net-analyzer/tcpslice/tcpslice-1.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit verify-sig
+
+DESCRIPTION="Extract and concatenate portions of pcap files"
+HOMEPAGE="http://www.tcpdump.org/ https://github.com/the-tcpdump-group/tcpslice"
+SRC_URI="https://www.tcpdump.org/release/${P}.tar.gz
+ verify-sig? ( https://www.tcpdump.org/release/${P}.tar.gz.sig )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-tcpdump )"
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/tcpdump.asc"