summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpreplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 02:18:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 02:18:43 +0100
commit683e8a42fb208dee0d6289d084fb39ab17aa2b60 (patch)
tree7dc14cd46e691df01335e2acfa0caa749440e302 /net-analyzer/tcpreplay
parentb8a68ff14101189bc5330d9afa620b8c45212032 (diff)
gentoo auto-resync : 12:06:2023 - 02:18:43
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/Manifest2
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.4.4.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index fe623b8d13d6..f8444373a0ac 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,5 +1,7 @@
AUX tcpreplay-4.3.0-enable-pcap_findalldevs.patch 333 BLAKE2B 1beb39a7263bf8491998760e4a62ac8908300e28c43500812d37d2512f9d63fcd175b93c1b384e03e9570e741dd95dea09ead017a014a4b62b3449833fe9b248 SHA512 3d035736c0656f6ace85b45af595866e06c8464641023e9d1606c288e598cde18eb96b1be8300514f6f31bc83756ae76b436402666036456571201ca38fe5026
DIST tcpreplay-4.4.3.tar.xz 750072 BLAKE2B 218fe1c5faab0fdd75a031afce8f468c85886a4cf21a4d9bd34089bd106756ee0e65e0df605efecb3260ccff266553a44d8ee10249b35524a044c6c5db86fcc7 SHA512 d8186a5faf3fbe5505da34cfc466c0375c4f298c997fe85505ea898c8c1241c16f98269596b682983a3e5cbd8493882334c925ff750d95995f3b13c5b83357cf
+DIST tcpreplay-4.4.4.tar.xz 748344 BLAKE2B 05f586c9d68e1ee47fc5dfdbf14d866ccbd921a5734a52de4ba6c1f33f37628e510eddbf9059130c9858207690ec2c14dfbf3819f923436aa64fcc3fc2ce074d SHA512 a6907c98779c96b2acf53e2f13e832f2c9a7ee840acc40d23c7290c2ceefb5885d314453dec9463069218011bee86bb7df057966120aacd6cddda942821aea9b
EBUILD tcpreplay-4.4.3.ebuild 2131 BLAKE2B 07d302b1b525d49b2ca6a89faca08a55458ee6444e66914e73310aa749ba1934fff2bec38e01d986acfeefb2def4215ff7802042219527a2938adf7a32a6726b SHA512 727a8f56c3390ed18f54e89a14a0a2a066e0436522fc332d5f7a433e9c52a7671b7965efddb572c542004e06af847cf31d3a5c333a02879fc07de4465e63af6b
+EBUILD tcpreplay-4.4.4.ebuild 2133 BLAKE2B 3e3fa8a2093a3a203bba0a430367d9cd75fa56349c1079da3d08ec92c433f47ae4f0d5d0bb8ebedc9cd61498c9ee52d65dcf3165db54bd825ad7548be8de3248 SHA512 df38e0d80932a21a04d414a2f966be66d9477e8d6faa368170f89a4a5df4ab97cf51c23bb8a3d5b979476fe9de5e15c9f4a436f2806c2061db223964937f7655
EBUILD tcpreplay-9999.ebuild 2133 BLAKE2B 24055b46b8746954e05cfaf88695389ef7e17171ba16f4b6de166f40e23ce3a7ef5f82f2915fc016bd6cc637ecf473fc90ed791111e87e7d905f83d0ca380629 SHA512 033159087ec5edb13a1c87a94489ffcf30b085b58707581b1de8d5f176511204a1e907e19c70b1aa46ec81678c0cb16b7bf086eb4d6c0f0562a6d74218d02718
MISC metadata.xml 1117 BLAKE2B f269c4d3da94e3fb52ad80b840c6d5b8d4acb0181dd1c370bedd88bcf75e6933f21f304f3ed5435dc601978acbef6396410d9beb96e4ec1ba1a7a53458b540c9 SHA512 bff9425e1ae71f5d106a5b2c844591db726192f356f54c6347fb9a6c10fef6b7b11cc59695b4f712d87f0359112b98ec514ce481fd824d6e343975631b105ea5
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.4.4.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.4.4.ebuild
new file mode 100644
index 000000000000..f953a68c1c37
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.4.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/appneta/tcpreplay"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~sparc ~x86"
+fi
+
+S="${WORKDIR}"/${P/_/-}
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+IUSE="debug pcapnav +tcpdump"
+
+# libpcapnav for pcapnav-config
+BDEPEND="
+ net-libs/libpcapnav
+ >=sys-devel/autogen-5.18.4[libopts]
+"
+DEPEND="
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ elibc_musl? ( sys-libs/fts-standalone )
+ pcapnav? ( net-libs/libpcapnav )
+ tcpdump? ( net-analyzer/tcpdump )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use elibc_musl && append-flags "-lfts"
+ # By default it uses static linking. Avoid that, bug #252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
+ --enable-dynamic-link \
+ --enable-local-libopts \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]] ; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up."
+ die "self test failed - see ${S}/test/test.log"
+ }
+ fi
+}