summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpreplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /net-analyzer/tcpreplay
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/Manifest2
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index dcbbe9826cc7..af359979f221 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,5 +1,7 @@
AUX tcpreplay-4.3.0-enable-pcap_findalldevs.patch 333 BLAKE2B 1beb39a7263bf8491998760e4a62ac8908300e28c43500812d37d2512f9d63fcd175b93c1b384e03e9570e741dd95dea09ead017a014a4b62b3449833fe9b248 SHA512 3d035736c0656f6ace85b45af595866e06c8464641023e9d1606c288e598cde18eb96b1be8300514f6f31bc83756ae76b436402666036456571201ca38fe5026
DIST tcpreplay-4.3.1.tar.xz 746804 BLAKE2B c1feb541b8243b00b2fa6ee9742ced4ef47c58a58d3a95be88faa0fa4301da0cb962a620df724cd4526ea31e74a0e7d7161eb44afea37467a19976a20855e0e0 SHA512 2dbad1a88ed19db897cc1222883c02eb7f0808f64cafb3c3ef8f21c0cfcb14d3ebb92a8a01ea203ca128ed675d2e7dcdb30d0bce30eb79e729d9d45d309f9220
+DIST tcpreplay-4.3.2.tar.xz 747268 BLAKE2B 27cad902785975f9c7fbfb8abef24ae95fbc8812e0a4fabd3b1ecf74bb9f0a99cdb0c37db72c433296d3cebba89d0bbc90e944195e585bf2d1c2d93ef234c4f6 SHA512 641dd636d9c5c30637d0103f8b21da3ce234f9e3ed7ab4d2b20d004fc4a14301672dcd678b2d5e0eb90d55a97bcb0c4c67f31c790a5aa3c509a92d1142c5b7b9
EBUILD tcpreplay-4.3.1.ebuild 1921 BLAKE2B 901852df7b7c0ef75796e2313c1940a595f3c40fc9a62cf27caeffe45708e1e11a9d16c5e9bd01e3880b1b9391b728164347e21caf2168ad1c4414d825cfa42b SHA512 3ad59027e0d85ee1230cc79e3b05024b979e9fc49bae10aad3a83e21cb5684847105264df4c354959561b593a39937f851f8dc87176b53fcef3694c4d3997da4
+EBUILD tcpreplay-4.3.2.ebuild 1923 BLAKE2B 9c2056a5d46252ea15586f90e19dbe9d7a3ef8faf98163029b1531fc57160f6b3201dc68a144334b5a001666c499059064cf76b4c362a145832d7a0f846c5a31 SHA512 61d5805bcc3041f1b45d70324a49179d0ed916768abec93ed0c099453a51e2fa48ff3f01013831c0c929489901e17ab8c0e6ff100bc79677078f4ba7efbe2680
EBUILD tcpreplay-999999.ebuild 1860 BLAKE2B 7e5894985eb08e8b82aa434bb30c096679c50995203be58c2490374e9163502b50585fe2afc530e9de918441181d1deef76ea999030bc40d4a077ca6b6da83e1 SHA512 36de21822cd88ab40c1c7b70c762be1284391bbb42ad0b56b9d10ddfe3de4b5f9e9195c41d900dc57fe84064003cadb389b3fefc13283e871e2adc14dfb02ebd
MISC metadata.xml 1116 BLAKE2B 23c8b7009a77b68831affc57432a87a31fde213d7e7ee88f68ced4a4e21a56c55f97497e610fc486a42c699759ef1edf1904fa9b0fe976df4fc9930535f97037 SHA512 58cb13a648ba7b9f9fd8c7a7cdfd37d56f0d7b957824a55d63001a8708f93d529b29e52df051bdce0c87eb672d24c7b2c35ee8a1e94ba062e2a1e12dd0d0ee1b
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild
new file mode 100644
index 000000000000..a73ca26a8cc6
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+LICENSE="BSD GPL-3"
+SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV/_/-}/${P/_/-}.tar.xz -> ${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE="debug pcapnav +tcpdump"
+
+DEPEND="
+ >=sys-devel/autogen-5.18.4[libopts]
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ tcpdump? ( net-analyzer/tcpdump )
+ pcapnav? ( net-libs/libpcapnav )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ docs/{CHANGELOG,CREDIT,HACKING,TODO}
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
+)
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # By default it uses static linking. Avoid that, bug 252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
+ --enable-dynamic-link \
+ --enable-local-libopts \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]]; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep || die "self test failed - see ${S}/test/test.log"
+ else
+ emake -j1 test || {
+ ewarn "Note that some tests require eth0 iface to be up." ;
+ die "self test failed - see ${S}/test/test.log" ; }
+ fi
+}