summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpreen/tcpreen-1.4.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 03:12:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 03:12:12 +0000
commit4e0f61672a4cd8a3d8afc21e9afc2a7acd849976 (patch)
tree20cba6f816bb34fdd956935e64d4432ed2427c65 /net-analyzer/tcpreen/tcpreen-1.4.4-r1.ebuild
parentd479c9c5c724c7b1300a98e44975f31f4f2e51dd (diff)
gentoo auto-resync : 07:12:2022 - 03:12:11
Diffstat (limited to 'net-analyzer/tcpreen/tcpreen-1.4.4-r1.ebuild')
-rw-r--r--net-analyzer/tcpreen/tcpreen-1.4.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/tcpreen/tcpreen-1.4.4-r1.ebuild b/net-analyzer/tcpreen/tcpreen-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..3191689b7a26
--- /dev/null
+++ b/net-analyzer/tcpreen/tcpreen-1.4.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="TCP network re-engineering tool"
+HOMEPAGE="https://www.remlab.net/tcpreen/"
+SRC_URI="https://www.remlab.net/files/${PN}/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-literal-suffix.patch )
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}