summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpdump/tcpdump-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-analyzer/tcpdump/tcpdump-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-9999.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-9999.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-9999.ebuild b/net-analyzer/tcpdump/tcpdump-9999.ebuild
index ac642f4be7b4..b0c0a0baa597 100644
--- a/net-analyzer/tcpdump/tcpdump-9999.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic toolchain-funcs user
+inherit autotools git-r3 user
DESCRIPTION="A Tool for network monitoring and data acquisition"
EGIT_REPO_URI="https://github.com/the-tcpdump-group/tcpdump"
@@ -32,9 +32,11 @@ RDEPEND="
libressl? ( dev-libs/libressl:= )
)
"
+BDEPEND="
+ drop-root? ( virtual/pkgconfig )
+"
DEPEND="
${RDEPEND}
- drop-root? ( virtual/pkgconfig )
test? (
>=net-libs/libpcap-1.9.1
dev-lang/perl
@@ -52,22 +54,20 @@ pkg_setup() {
}
src_prepare() {
- default
-
sed -i -e '/^eapon1/d;' tests/TESTLIST || die
# bug 630394
sed -i -e '/^nbns-valgrind/d' tests/TESTLIST || die
+
+ default
+
+ eautoreconf
}
src_configure() {
- if use drop-root; then
- append-cppflags -DHAVE_CAP_NG_H
- export LIBS=$( $(tc-getPKG_CONFIG) --libs libcap-ng )
- fi
-
econf \
$(use_enable samba smb) \
+ $(use_with drop-root cap-ng) \
$(use_with drop-root chroot '') \
$(use_with smi) \
$(use_with ssl crypto "${ESYSROOT}/usr") \