summaryrefslogtreecommitdiff
path: root/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-analyzer/tcpdump/tcpdump-4.99.0.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-analyzer/tcpdump/tcpdump-4.99.0.ebuild')
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.99.0.ebuild28
1 files changed, 23 insertions, 5 deletions
diff --git a/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild b/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild
index 2edd75502e32..d06df7164dbd 100644
--- a/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-4.99.0.ebuild
@@ -7,18 +7,31 @@ inherit autotools
DESCRIPTION="A tool for network monitoring and data acquisition"
HOMEPAGE="https://www.tcpdump.org/ https://github.com/the-tcpdump-group/tcpdump"
-SRC_URI="https://github.com/the-tcpdump-group/${PN}/archive/${P/_}.tar.gz"
-S="${WORKDIR}/${PN}-${P/_}"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/the-tcpdump-group/tcpdump"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/tcpdump.asc
+ inherit verify-sig
+
+ # Note: drop -upstream on bump, this is just because we switched to the official
+ # distfiles for verify-sig
+ SRC_URI="https://www.tcpdump.org/release/${P}.tar.gz -> ${P}-upstream.tar.gz"
+ SRC_URI+=" verify-sig? ( https://www.tcpdump.org/release/${P}.tar.gz.sig -> ${P}-upstream.tar.gz.sig )"
+
+ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="+drop-root libressl +smi +ssl +samba suid test"
+REQUIRED_USE="test? ( samba )"
+
# Assorted failures: bug #768498
RESTRICT="test"
-REQUIRED_USE="test? ( samba )"
-BDEPEND="drop-root? ( virtual/pkgconfig )"
RDEPEND="
net-libs/libpcap
drop-root? (
@@ -43,6 +56,11 @@ DEPEND="
dev-lang/perl
)
"
+BDEPEND="drop-root? ( virtual/pkgconfig )"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+=" verify-sig? ( app-crypt/openpgp-keys-tcpdump )"
+fi
PATCHES=(
"${FILESDIR}"/${PN}-9999-libdir.patch