summaryrefslogtreecommitdiff
path: root/net-analyzer/synscan/synscan-5.02.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /net-analyzer/synscan/synscan-5.02.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'net-analyzer/synscan/synscan-5.02.ebuild')
-rw-r--r--net-analyzer/synscan/synscan-5.02.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/synscan/synscan-5.02.ebuild b/net-analyzer/synscan/synscan-5.02.ebuild
new file mode 100644
index 000000000000..734a7d101fba
--- /dev/null
+++ b/net-analyzer/synscan/synscan-5.02.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils
+
+DESCRIPTION="A fast asynchronous half-open TCP portscanner"
+HOMEPAGE="http://www.digit-labs.org/files/tools/synscan/"
+SRC_URI="http://www.digit-labs.org/files/tools/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kernel_FreeBSD kernel_linux"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-destdir.patch"
+)
+
+src_prepare() {
+ default
+ mv "$S"/configure.in "$S"/configure.ac || die
+ eautoconf
+}
+
+src_configure() {
+ econf --prefix="${EPREFIX}"/usr
+}
+
+src_compile() {
+ local _target
+ use kernel_FreeBSD && _target=freebsd
+ use kernel_linux && _target=linux
+
+ emake ${_target}
+}