summaryrefslogtreecommitdiff
path: root/net-analyzer/sngrep/sngrep-1.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-18 09:41:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-18 09:41:23 +0000
commitd93ba9788a6ad1e5da2bf47e804456ded6d5c65c (patch)
treee01c10bcfe477cecf1770c8a8186e4a5344057b9 /net-analyzer/sngrep/sngrep-1.6.0-r1.ebuild
parent7bf32644d8b70a318475609992d8e4853ec4ec0e (diff)
gentoo auto-resync : 18:12:2022 - 09:41:22
Diffstat (limited to 'net-analyzer/sngrep/sngrep-1.6.0-r1.ebuild')
-rw-r--r--net-analyzer/sngrep/sngrep-1.6.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/sngrep/sngrep-1.6.0-r1.ebuild b/net-analyzer/sngrep/sngrep-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..89771013483f
--- /dev/null
+++ b/net-analyzer/sngrep/sngrep-1.6.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Ncurses SIP Messages flow viewer"
+HOMEPAGE="https://github.com/irontec/sngrep"
+SRC_URI="https://github.com/irontec/sngrep/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eep gnutls pcre ssl zlib"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:=[unicode(+)]
+ ssl? (
+ !gnutls? ( dev-libs/openssl:= )
+ gnutls? ( net-libs/gnutls:= )
+ )
+ pcre? ( dev-libs/libpcre2 )
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-ipv6
+ --enable-unicode
+ --without-pcre
+ $(use_enable eep)
+ $(use_with pcre pcre2)
+ $(use_with ssl $(usex gnutls gnutls openssl))
+ $(use_with zlib)
+ )
+
+ econf "${myeconfargs[@]}"
+}