summaryrefslogtreecommitdiff
path: root/net-analyzer/sngrep/sngrep-1.4.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /net-analyzer/sngrep/sngrep-1.4.7-r1.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'net-analyzer/sngrep/sngrep-1.4.7-r1.ebuild')
-rw-r--r--net-analyzer/sngrep/sngrep-1.4.7-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/sngrep/sngrep-1.4.7-r1.ebuild b/net-analyzer/sngrep/sngrep-1.4.7-r1.ebuild
new file mode 100644
index 000000000000..3af1d0702e40
--- /dev/null
+++ b/net-analyzer/sngrep/sngrep-1.4.7-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Ncurses SIP Messages flow viewer"
+HOMEPAGE="https://github.com/irontec/sngrep"
+SRC_URI="https://github.com/irontec/sngrep/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eep gnutls ipv6 openssl pcre unicode"
+REQUIRED_USE="
+ gnutls? ( !openssl )
+"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:=[unicode(+)?]
+ openssl? ( dev-libs/openssl:0= )
+ gnutls? ( net-libs/gnutls )
+ pcre? ( dev-libs/libpcre )
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.7-tinfo.patch
+ "${FILESDIR}"/${PN}-1.4.7-LDFLAGS.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable eep) \
+ $(use_enable ipv6) \
+ $(use_enable unicode) \
+ $(use_with gnutls) \
+ $(use_with openssl) \
+ $(use_with pcre)
+}