summaryrefslogtreecommitdiff
path: root/net-analyzer/sngrep/sngrep-1.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /net-analyzer/sngrep/sngrep-1.4.5.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'net-analyzer/sngrep/sngrep-1.4.5.ebuild')
-rw-r--r--net-analyzer/sngrep/sngrep-1.4.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/sngrep/sngrep-1.4.5.ebuild b/net-analyzer/sngrep/sngrep-1.4.5.ebuild
new file mode 100644
index 000000000000..f9c686aba4d0
--- /dev/null
+++ b/net-analyzer/sngrep/sngrep-1.4.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Ncurses SIP Messages flow viewer"
+HOMEPAGE="https://github.com/irontec/sngrep"
+SRC_URI="${HOMEPAGE}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="eep gnutls ipv6 openssl pcre unicode"
+REQUIRED_USE="
+ gnutls? ( !openssl )
+"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:*[unicode?]
+ openssl? ( dev-libs/openssl:* )
+ gnutls? ( net-libs/gnutls )
+"
+RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.5-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable eep) \
+ $(use_enable ipv6) \
+ $(use_enable unicode) \
+ $(use_with gnutls) \
+ $(use_with openssl) \
+ $(use_with pcre)
+}