summaryrefslogtreecommitdiff
path: root/net-analyzer/snallygaster/snallygaster-0.0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /net-analyzer/snallygaster/snallygaster-0.0.12.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'net-analyzer/snallygaster/snallygaster-0.0.12.ebuild')
-rw-r--r--net-analyzer/snallygaster/snallygaster-0.0.12.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-analyzer/snallygaster/snallygaster-0.0.12.ebuild b/net-analyzer/snallygaster/snallygaster-0.0.12.ebuild
new file mode 100644
index 000000000000..578572f0bfbb
--- /dev/null
+++ b/net-analyzer/snallygaster/snallygaster-0.0.12.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="Finds file leaks and other security problems on HTTP servers"
+HOMEPAGE="https://github.com/hannob/snallygaster"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/dnspython
+ dev-python/urllib3
+ dev-python/beautifulsoup4"
+RDEPEND="${DEPEND}"
+DOCS=( README.md TESTS.md )
+
+# Only codingstyle and similar tests, require dependencies
+# not packaged in Gentoo
+RESTRICT="test"