summaryrefslogtreecommitdiff
path: root/net-analyzer/slurm/slurm-0.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /net-analyzer/slurm/slurm-0.4.3.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'net-analyzer/slurm/slurm-0.4.3.ebuild')
-rw-r--r--net-analyzer/slurm/slurm-0.4.3.ebuild34
1 files changed, 14 insertions, 20 deletions
diff --git a/net-analyzer/slurm/slurm-0.4.3.ebuild b/net-analyzer/slurm/slurm-0.4.3.ebuild
index 95641beb1b22..da86bb68d8bf 100644
--- a/net-analyzer/slurm/slurm-0.4.3.ebuild
+++ b/net-analyzer/slurm/slurm-0.4.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils
+EAPI=7
+
+inherit cmake
DESCRIPTION="Realtime network interface monitor based on FreeBSD's pppstatus"
HOMEPAGE="https://github.com/mattthias/slurm"
@@ -12,26 +13,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-RDEPEND="
- sys-libs/ncurses:*
-"
-DEPEND="
- ${RDEPEND}
-"
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-upstream"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.3.3-overflow.patch
"${FILESDIR}"/${P}-tinfo.patch
"${FILESDIR}"/${P}-version.patch
-)
-DOCS=(
- AUTHORS
- ChangeLog
- FAQ
- KEYS
- README
- THANKS
- THEMES.txt
- TODO
+ "${FILESDIR}"/${P}-fix-includes.patch
)
-S=${WORKDIR}/${PN}-upstream
+src_install() {
+ cmake_src_install
+ dodoc KEYS THEMES.txt
+}