summaryrefslogtreecommitdiff
path: root/net-analyzer/siphon/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/siphon/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/siphon/files')
-rw-r--r--net-analyzer/siphon/files/siphon-666-gentoo.patch19
-rw-r--r--net-analyzer/siphon/files/siphon-666-log.patch46
2 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/siphon/files/siphon-666-gentoo.patch b/net-analyzer/siphon/files/siphon-666-gentoo.patch
new file mode 100644
index 000000000000..eea6d93b802e
--- /dev/null
+++ b/net-analyzer/siphon/files/siphon-666-gentoo.patch
@@ -0,0 +1,19 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ CC = gcc
+ CCFLAGS = -Wall -pthread -ggdb
+-CFLAGS = -Wall -O2 -pthread -ggdb -I.
++CFLAGS += -pthread -Wall -I.
+ LIBS = -lpcap
+ OBJS = parse.o sniff.o main.o log.o
+ SRCS = ${OBJS:.o=.c}
+@@ -9,7 +9,7 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CCFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
++ $(CC) $(CCFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ clean:
+ rm -f $(OBJS) *~ *.core core siphon
diff --git a/net-analyzer/siphon/files/siphon-666-log.patch b/net-analyzer/siphon/files/siphon-666-log.patch
new file mode 100644
index 000000000000..07d2de4d4d12
--- /dev/null
+++ b/net-analyzer/siphon/files/siphon-666-log.patch
@@ -0,0 +1,46 @@
+--- a/main.c
++++ b/main.c
+@@ -98,7 +98,7 @@
+ pti_parse.pti_pd[1] = pd_parse2log[1];
+
+ pthread_create (&parse_thread, NULL, (void *) parse, &pti_parse);
+- pthread_create(&log_thread,NULL,(void *)log, (void *)pd_parse2log[0]);
++ pthread_create(&log_thread,NULL,(void *)siphon_log, (void *)pd_parse2log[0]);
+ pthread_create (&sniff_thread, NULL, (void *) sniff_network,
+ &pd_sniff2parse[1]);
+
+--- a/log.c
++++ b/log.c
+@@ -19,7 +19,7 @@
+
+ int tag = 0;
+
+-void *log(void *pipe)
++void *siphon_log(void *pipe)
+ {
+ struct parse2log *info;
+ char hashed[100], buf[1024], *os, *proto = NULL, *df;
+@@ -137,10 +137,10 @@
+ FILE *osprints;
+ static char line[80], *oswin, *osttl, *osdf, *os, hexed[10];
+ static int check = 0;
+- osprints = fopen("osprints.conf","r");
++ osprints = fopen("/etc/osprints.conf","r");
+
+ if(!osprints) {
+- perror("Unable to find osprints.conf\n");
++ perror("Unable to find /etc/osprints.conf\n");
+ return "Unknown";
+ }
+
+--- a/siphon.h
++++ b/siphon.h
+@@ -49,7 +49,7 @@
+
+ void *sniff_network (void *);
+ void *parse (void *);
+-void *log(void *);
++void *siphon_log(void *);
+
+ char *device, *logfile;
+ int verbose, back;