summaryrefslogtreecommitdiff
path: root/net-analyzer/shodan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-26 09:56:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-26 09:56:45 +0100
commitf3471ff11210507b38c09f0e57df1bd601f629a5 (patch)
tree9931bc74efae95f78cd0270fde107c779d2dd482 /net-analyzer/shodan
parent5e5fb5c6d1e0af4b12dbee7de7d095df902ce2b6 (diff)
gentoo auto-resync : 26:08:2023 - 09:56:44
Diffstat (limited to 'net-analyzer/shodan')
-rw-r--r--net-analyzer/shodan/Manifest4
-rw-r--r--net-analyzer/shodan/shodan-1.30.0.ebuild36
-rw-r--r--net-analyzer/shodan/shodan-9999.ebuild8
3 files changed, 43 insertions, 5 deletions
diff --git a/net-analyzer/shodan/Manifest b/net-analyzer/shodan/Manifest
index 80e64c4e6b7c..b300900b1b75 100644
--- a/net-analyzer/shodan/Manifest
+++ b/net-analyzer/shodan/Manifest
@@ -1,4 +1,6 @@
DIST shodan-1.28.0.gh.tar.gz 51277 BLAKE2B e2cd4c322ccdd1d81c998dc810c56b85de903afe9c3a59adc231d382779806909a78e994ff163639468dd9af1e8f7a547953b0e2304ac167ed7cf9c437d69adc SHA512 cb2476faf2c435d29823635e5262bdf6b224b2a5f19b77513fb6e920f4d042b15a7fd23cea7e2a29bc73b00be188dfac16f945fba090da28a72d0342357232c3
+DIST shodan-1.30.0.tar.gz 57790 BLAKE2B 1c3c030e84d31dc79ad737b71e63ce6c9218441be04ec94b4144013545e0d7dd79f1e25e51af1811cdd624f2f32b128e5aeb7dbc8d71b21741712733ca4b6d39 SHA512 996555945f4d874cb0fa3c596e6fad9298f7af396c0e94d75b8e9e103d4a2d7dd33ed8af24a218c753117231a0713caa971106f2152bc429d7c8b5c07b00dbc6
EBUILD shodan-1.28.0.ebuild 897 BLAKE2B 13deb81e710601c0fdcf5fb7a93ce9f94afe7eb0351038bd560a532b33e49231537a35d9da259b48aa0532947f49308bf2a6ebae3196bc5c36653a6fc06b9b67 SHA512 88ee098bfd3411a8b9349750e31f1828bf80612a6f77f344206b85f5101f2b82b0b71cfeacaf4cc0e5481539e1fff0b702fbbe0f9ef75004cbcc85461c1b1b74
-EBUILD shodan-9999.ebuild 892 BLAKE2B 82f5220e588eec40c31da4208c67692747b0466a5a30e816db9719f9230355bba185b94452dc3570f00d7c75306ec275cc57d959f679919d1ea5bdda13c474ab SHA512 306dc86e618044a549afb76acb378fd7b6ba739668162ed5ac59643f79469a79db675692a94d9241e56eee3b131a4b25c78846e70214a58f61c3591733bffb76
+EBUILD shodan-1.30.0.ebuild 814 BLAKE2B b76f650e38529aca24bbdae2e3597fb872e5fb35903f6dfb85fe9abe7483020460d918c45edc50fe40b3accae5f3e2f5c821c34050e93eb76f09ebe6dc325347 SHA512 ec504b9653062ec5c61d73677972a39f876175de0724a3b16e377a39ebda562232c339ceebeb4d72858cd881e7ec3330a0304396028fe1d4eca39490be649379
+EBUILD shodan-9999.ebuild 821 BLAKE2B d940ee350504a58c8169e90f5ade9af407758afc4eee2fa2dae80fb17ccf2caeddeda595e83376a2dcea07aa8ef8f7393456a1684411f53dbad9f804989c5a25 SHA512 be7051a3c6ec6dc9ed42fbfea4e8eefba584a62c1a5266666990f7631a5762f742197eb486d4d6816a00319e2323234f9343d3ed7af90f7c067c1631a409ac04
MISC metadata.xml 864 BLAKE2B 1eeb1a52185cac9195cc62b3e74d0dfb7df895666303bbbf562a4b75363b0179137de3cf99c8d650f59a13f972bfbdece972783ba282870a501289950d9cec6c SHA512 737b931e809418e0fe940ac6026d52edce42d0b5da30372394403210688caab00d8c99807b640de74383f3e4daafc3e09764bdde31e54d9898a11aff60f4f2c4
diff --git a/net-analyzer/shodan/shodan-1.30.0.ebuild b/net-analyzer/shodan/shodan-1.30.0.ebuild
new file mode 100644
index 000000000000..9fd2907ed8ae
--- /dev/null
+++ b/net-analyzer/shodan/shodan-1.30.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"
diff --git a/net-analyzer/shodan/shodan-9999.ebuild b/net-analyzer/shodan/shodan-9999.ebuild
index 984c33c3f1f6..c530e8f47fb4 100644
--- a/net-analyzer/shodan/shodan-9999.ebuild
+++ b/net-analyzer/shodan/shodan-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
DESCRIPTION="The official Python library for Shodan"
@@ -16,9 +16,8 @@ if [[ ${PV} = "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
else
- SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV}"
- KEYWORDS="~amd64 ~x86"
+ inherit pypi
+ KEYWORDS="~amd64 ~loong ~x86"
fi
LICENSE="MIT"
@@ -29,6 +28,7 @@ RDEPEND="
dev-python/click-plugins[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
dev-python/xlsxwriter[${PYTHON_USEDEP}]
"