summaryrefslogtreecommitdiff
path: root/net-analyzer/shodan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 07:07:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 07:07:57 +0000
commitbed152ba1fc2f1316eaefb5c3d24d48195560f76 (patch)
tree0564fbaf0c7ff23390031d68b741e89a40071333 /net-analyzer/shodan
parent57c2e006d0af9ab77ced676461d7100cade4a716 (diff)
gentoo auto-resync : 23:11:2022 - 07:07:57
Diffstat (limited to 'net-analyzer/shodan')
-rw-r--r--net-analyzer/shodan/Manifest4
-rw-r--r--net-analyzer/shodan/metadata.xml22
-rw-r--r--net-analyzer/shodan/shodan-1.28.0.ebuild36
-rw-r--r--net-analyzer/shodan/shodan-9999.ebuild36
4 files changed, 98 insertions, 0 deletions
diff --git a/net-analyzer/shodan/Manifest b/net-analyzer/shodan/Manifest
new file mode 100644
index 000000000000..d71ade2af473
--- /dev/null
+++ b/net-analyzer/shodan/Manifest
@@ -0,0 +1,4 @@
+DIST shodan-1.28.0.gh.tar.gz 51277 BLAKE2B e2cd4c322ccdd1d81c998dc810c56b85de903afe9c3a59adc231d382779806909a78e994ff163639468dd9af1e8f7a547953b0e2304ac167ed7cf9c437d69adc SHA512 cb2476faf2c435d29823635e5262bdf6b224b2a5f19b77513fb6e920f4d042b15a7fd23cea7e2a29bc73b00be188dfac16f945fba090da28a72d0342357232c3
+EBUILD shodan-1.28.0.ebuild 887 BLAKE2B c570b05ccb40ac49e283d19c14037df36f336c160bf9b574b300b6471d05d379bd284ff1967785289780ffafe0f66f98f9101288394e33fae223ca02f937f8d9 SHA512 64c05f77a2a1dcd7cfb843cf3fb74b0b7ba0a458515a3040612c1ee2c8640634a70d01d523cfcb4ad54bce918d53086999ef66f732a228e4377b11e94a4330a8
+EBUILD shodan-9999.ebuild 887 BLAKE2B c570b05ccb40ac49e283d19c14037df36f336c160bf9b574b300b6471d05d379bd284ff1967785289780ffafe0f66f98f9101288394e33fae223ca02f937f8d9 SHA512 64c05f77a2a1dcd7cfb843cf3fb74b0b7ba0a458515a3040612c1ee2c8640634a70d01d523cfcb4ad54bce918d53086999ef66f732a228e4377b11e94a4330a8
+MISC metadata.xml 864 BLAKE2B 1eeb1a52185cac9195cc62b3e74d0dfb7df895666303bbbf562a4b75363b0179137de3cf99c8d650f59a13f972bfbdece972783ba282870a501289950d9cec6c SHA512 737b931e809418e0fe940ac6026d52edce42d0b5da30372394403210688caab00d8c99807b640de74383f3e4daafc3e09764bdde31e54d9898a11aff60f4f2c4
diff --git a/net-analyzer/shodan/metadata.xml b/net-analyzer/shodan/metadata.xml
new file mode 100644
index 000000000000..506479336f85
--- /dev/null
+++ b/net-analyzer/shodan/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Shodan is a search engine for Internet-connected devices. Google lets
+ you search for websites, Shodan lets you search for devices. This
+ library provides developers easy access to all of the data stored in
+ Shodan in order to automate tasks and integrate into existing tools.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">achillean/shodan-python</remote-id>
+ <remote-id type="pypi">shodan</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/shodan/shodan-1.28.0.ebuild b/net-analyzer/shodan/shodan-1.28.0.ebuild
new file mode 100644
index 000000000000..c66417af8251
--- /dev/null
+++ b/net-analyzer/shodan/shodan-1.28.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"
diff --git a/net-analyzer/shodan/shodan-9999.ebuild b/net-analyzer/shodan/shodan-9999.ebuild
new file mode 100644
index 000000000000..c66417af8251
--- /dev/null
+++ b/net-analyzer/shodan/shodan-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"