summaryrefslogtreecommitdiff
path: root/net-analyzer/shodan/shodan-1.30.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-20 14:08:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-20 14:08:57 +0000
commit6aa0d33a65c735f3148967b62316c2e71f43589a (patch)
tree4ddfb479a93b928f4ad0507a58e779e6de3eb403 /net-analyzer/shodan/shodan-1.30.1.ebuild
parenta332b8e207ac6a51fa349c699b486d870c9cdc70 (diff)
gentoo auto-resync : 20:01:2024 - 14:08:56
Diffstat (limited to 'net-analyzer/shodan/shodan-1.30.1.ebuild')
-rw-r--r--net-analyzer/shodan/shodan-1.30.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/shodan/shodan-1.30.1.ebuild b/net-analyzer/shodan/shodan-1.30.1.ebuild
new file mode 100644
index 000000000000..bc9092e7acc5
--- /dev/null
+++ b/net-analyzer/shodan/shodan-1.30.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="The official Python library for Shodan"
+HOMEPAGE="https://github.com/achillean/shodan-python"
+
+MY_PN="${PN}-python"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~loong ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+"
+
+# Test requires API key
+RESTRICT="test"