summaryrefslogtreecommitdiff
path: root/net-analyzer/sflowtool/sflowtool-5.06.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-analyzer/sflowtool/sflowtool-5.06.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-analyzer/sflowtool/sflowtool-5.06.ebuild')
-rw-r--r--net-analyzer/sflowtool/sflowtool-5.06.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/sflowtool/sflowtool-5.06.ebuild b/net-analyzer/sflowtool/sflowtool-5.06.ebuild
new file mode 100644
index 000000000000..1f5a093d2111
--- /dev/null
+++ b/net-analyzer/sflowtool/sflowtool-5.06.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="sflowtool is a utility for collecting and processing sFlow data"
+HOMEPAGE="
+ https://inmon.com/technology/sflowTools.php
+ https://github.com/sflow/sflowtool
+"
+SRC_URI="https://github.com/sflow/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="inmon-sflow"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+src_configure() {
+ append-cppflags -DSPOOFSOURCE
+ use debug && append-cppflags -DDEBUG
+
+ default
+}
+
+src_install() {
+ default
+ dobin scripts/sflowenable
+}