summaryrefslogtreecommitdiff
path: root/net-analyzer/scapy/scapy-2.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /net-analyzer/scapy/scapy-2.4.4.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'net-analyzer/scapy/scapy-2.4.4.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-2.4.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-2.4.4.ebuild b/net-analyzer/scapy/scapy-2.4.4.ebuild
new file mode 100644
index 000000000000..503c24d45f18
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/ipython
+ dev-python/matplotlib
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpdump
+ net-analyzer/tcpreplay
+ net-libs/libpcap
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ if ! [[ -f ${PN}/VERSION ]]; then
+ echo ${PV} > ${PN}/VERSION || die
+ else
+ die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}