summaryrefslogtreecommitdiff
path: root/net-analyzer/sancp/sancp-1.6.1-r7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-analyzer/sancp/sancp-1.6.1-r7.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-analyzer/sancp/sancp-1.6.1-r7.ebuild')
-rw-r--r--net-analyzer/sancp/sancp-1.6.1-r7.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/net-analyzer/sancp/sancp-1.6.1-r7.ebuild b/net-analyzer/sancp/sancp-1.6.1-r7.ebuild
index e18588995cbb..f3ea7b0a3461 100644
--- a/net-analyzer/sancp/sancp-1.6.1-r7.ebuild
+++ b/net-analyzer/sancp/sancp-1.6.1-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,15 +7,14 @@ inherit toolchain-funcs
DESCRIPTION="collect network traffic statistics and store them in pcap format"
HOMEPAGE="https://sourceforge.net/projects/sancp/"
-SRC_URI="
- http://www.metre.net/files/${P}.tar.gz
+SRC_URI="http://www.metre.net/files/${P}.tar.gz
http://sancp.sourceforge.net/${PN}-1.6.1.fix200511.a.patch
http://sancp.sourceforge.net/${PN}-1.6.1.fix200511.b.patch
http://sancp.sourceforge.net/${PN}-1.6.1.fix200601.c.patch
http://sancp.sourceforge.net/${PN}-1.6.1.fix200606.d.patch
-"
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-1.6.1-musl.patch.bz2"
-LICENSE="QPL-1.0 GPL-2" # GPL-2 for init script
+LICENSE="QPL-1.0 GPL-2" # GPL-2 for init script
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="sguil"
@@ -27,20 +26,17 @@ RDEPEND="
DEPEND="${RDEPEND}"
PATCHES=(
+ "${DISTDIR}"/${PN}-1.6.1.fix200511.a.patch
+ "${DISTDIR}"/${PN}-1.6.1.fix200511.b.patch
+ # bug 138337
+ "${DISTDIR}"/${PN}-1.6.1.fix200601.c.patch
+ "${DISTDIR}"/${PN}-1.6.1.fix200606.d.patch
"${FILESDIR}"/${PN}-1.6.1-compiler.patch
"${FILESDIR}"/${PN}-1.6.1-gcc6.patch
"${FILESDIR}"/${PN}-1.6.1-extern.patch
+ "${WORKDIR}"/${PN}-1.6.1-musl.patch
)
-src_prepare() {
- eapply "${DISTDIR}"/${PN}-1.6.1.fix200511.a.patch
- eapply "${DISTDIR}"/${PN}-1.6.1.fix200511.b.patch
- # bug 138337
- eapply "${DISTDIR}"/${PN}-1.6.1.fix200601.c.patch
- eapply "${DISTDIR}"/${PN}-1.6.1.fix200606.d.patch
- default
-}
-
src_compile() {
tc-export CC CXX
emake CFLAGS="${CXXFLAGS}"