summaryrefslogtreecommitdiff
path: root/net-analyzer/rrdtool/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/rrdtool/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/rrdtool/files')
-rw-r--r--net-analyzer/rrdtool/files/rrdcached.confd8
-rw-r--r--net-analyzer/rrdtool/files/rrdcached.init13
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.4.7-configure.ac.patch21
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.4.9-disable-rrd_graph-cgi.patch49
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.4.9-disable-rrd_graph-perl.patch53
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.5.0_rc1-disable-rrd_graph-lua.patch12
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.5.0_rc1-disable-rrd_graph-python.patch38
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.5.5-rpn1.output3
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.5.5-rrdrados.pod68
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.6.0-configure.ac.patch25
-rw-r--r--net-analyzer/rrdtool/files/rrdtool-1.7.0-disable-rrd_graph-cgi.patch49
11 files changed, 339 insertions, 0 deletions
diff --git a/net-analyzer/rrdtool/files/rrdcached.confd b/net-analyzer/rrdtool/files/rrdcached.confd
new file mode 100644
index 000000000000..0463a7923461
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdcached.confd
@@ -0,0 +1,8 @@
+RRCACHE_ARGS="-l unix:/var/run/rrdcached.sock -j /var/lib/rrdcached/journal/ -F -b /var/lib/rrdcached/db/ -B"
+
+USER=""
+GROUP=""
+
+MODE=""
+
+MAXWAIT=30
diff --git a/net-analyzer/rrdtool/files/rrdcached.init b/net-analyzer/rrdtool/files/rrdcached.init
new file mode 100644
index 000000000000..51c2cbb6e818
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdcached.init
@@ -0,0 +1,13 @@
+#!/sbin/openrc-run
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/rrdcached"
+command_args="${RRCACHE_ARGS} -p /run/rrdcached.pid"
+start_stop_daemon_args="--quiet"
+description="RRDtool data caching daemon"
+
+depend() {
+ need localmount net
+ use logger
+}
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.4.7-configure.ac.patch b/net-analyzer/rrdtool/files/rrdtool-1.4.7-configure.ac.patch
new file mode 100644
index 000000000000..668adeee13ee
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.4.7-configure.ac.patch
@@ -0,0 +1,21 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -148,7 +148,7 @@
+ AC_PROG_CPP
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+-AC_PROG_LIBTOOL
++LT_INIT
+
+ dnl Try to detect/use GNU features
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
+@@ -204,9 +204,6 @@
+ AC_CHECK_FUNC(acos, , AC_CHECK_LIB(m, acos))
+
+
+-dnl add pic flag in any case this makes sure all our code is relocatable
+-eval `./libtool --config | grep pic_flag=`
+-CFLAGS="$CFLAGS $pic_flag"
+
+
+ dnl Checks for library functions.
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.4.9-disable-rrd_graph-cgi.patch b/net-analyzer/rrdtool/files/rrdtool-1.4.9-disable-rrd_graph-cgi.patch
new file mode 100644
index 000000000000..67f0ce2fb292
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.4.9-disable-rrd_graph-cgi.patch
@@ -0,0 +1,49 @@
+--- a/src/rrd_cgi.c
++++ b/src/rrd_cgi.c
+@@ -56,6 +56,7 @@
+ const char **);
+
+ /* call rrd_graph and insert appropriate image tag */
++#ifdef HAVE_RRD_GRAPH
+ char *drawgraph(
+ long,
+ const char **);
+@@ -64,6 +65,7 @@
+ char *drawprint(
+ long,
+ const char **);
++#endif /* HAVE_RRD_GRAPH */
+
+ /* pretty-print the <last></last> value for some.rrd via strftime() */
+ char *printtimelast(
+@@ -542,9 +544,13 @@
+ }
+ parse(&buffer, i, "<RRD::GETVAR", rrdgetvar);
+ parse(&buffer, i, "<RRD::GOODFOR", rrdgoodfor);
++#ifdef HAVE_RRD_GRAPH
+ parse(&buffer, i, "<RRD::GRAPH", drawgraph);
++#endif /* HAVE_RRD_GRAPH */
+ parse(&buffer, i, "<RRD::INCLUDE", includefile);
++#ifdef HAVE_RRD_GRAPH
+ parse(&buffer, i, "<RRD::PRINT", drawprint);
++#endif /* HAVE_RRD_GRAPH */
+ parse(&buffer, i, "<RRD::SETCONSTVAR", rrdsetvarconst);
+ parse(&buffer, i, "<RRD::SETENV", rrdsetenv);
+ parse(&buffer, i, "<RRD::SETVAR", rrdsetvar);
+@@ -929,7 +935,7 @@
+ }
+
+
+-
++#ifdef HAVE_RRD_GRAPH
+ char *drawgraph(
+ long argc,
+ const char **args)
+@@ -961,6 +967,7 @@
+ }
+ return NULL;
+ }
++#endif /* HAVE_RRD_GRAPH */
+
+ char *drawprint(
+ long argc,
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.4.9-disable-rrd_graph-perl.patch b/net-analyzer/rrdtool/files/rrdtool-1.4.9-disable-rrd_graph-perl.patch
new file mode 100644
index 000000000000..c68ca24a3e2f
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.4.9-disable-rrd_graph-perl.patch
@@ -0,0 +1,53 @@
+--- a/bindings/perl-shared/RRDs.xs
++++ b/bindings/perl-shared/RRDs.xs
+@@ -189,6 +189,7 @@
+ OUTPUT:
+ RETVAL
+
++#ifdef HAVE_RRD_GRAPH
+ SV *
+ rrd_graph(...)
+ PROTOTYPE: @
+@@ -235,6 +236,8 @@
+ PUSHs(sv_2mortal(newSViv(xsize)));
+ PUSHs(sv_2mortal(newSViv(ysize)));
+
++#endif /* HAVE_RRD_GRAPH */
++
+ SV *
+ rrd_fetch(...)
+ PROTOTYPE: @
+@@ -313,6 +316,7 @@
+ PUSHs(sv_2mortal(newSVuv(start_tmp)));
+ PUSHs(sv_2mortal(newSVuv(end_tmp)));
+
++#ifdef HAVE_RRD_GRAPH
+ int
+ rrd_xport(...)
+ PROTOTYPE: @
+@@ -371,6 +375,8 @@
+ PUSHs(sv_2mortal(newRV_noinc((SV*)names)));
+ PUSHs(sv_2mortal(newRV_noinc((SV*)retar)));
+
++#endif /* HAVE_RRD_GRAPH */
++
+ SV*
+ rrd_info(...)
+ PROTOTYPE: @
+@@ -397,6 +403,7 @@
+ OUTPUT:
+ RETVAL
+
++#ifdef HAVE_RRD_GRAPH
+ SV*
+ rrd_graphv(...)
+ PROTOTYPE: @
+@@ -410,6 +417,8 @@
+ OUTPUT:
+ RETVAL
+
++#endif /* HAVE_RRD_GRAPH */
++
+ int
+ rrd_dump(...)
+ PROTOTYPE: @
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.5.0_rc1-disable-rrd_graph-lua.patch b/net-analyzer/rrdtool/files/rrdtool-1.5.0_rc1-disable-rrd_graph-lua.patch
new file mode 100644
index 000000000000..6b3a3abf26bb
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.5.0_rc1-disable-rrd_graph-lua.patch
@@ -0,0 +1,12 @@
+--- a/bindings/lua/rrdlua.c
++++ b/bindings/lua/rrdlua.c
+@@ -367,7 +367,9 @@
+ #if defined(DINF)
+ {"info", lua_rrd_info},
+ {"updatev", lua_rrd_updatev},
++#ifdef HAVE_RRD_GRAPH
+ {"graphv", lua_rrd_graphv},
++#endif /* HAVE_RRD_GRAPH */
+ #endif
+ {NULL, NULL}
+ };
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.5.0_rc1-disable-rrd_graph-python.patch b/net-analyzer/rrdtool/files/rrdtool-1.5.0_rc1-disable-rrd_graph-python.patch
new file mode 100644
index 000000000000..db3daaf47345
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.5.0_rc1-disable-rrd_graph-python.patch
@@ -0,0 +1,38 @@
+--- a/bindings/python/rrdtoolmodule.c
++++ b/bindings/python/rrdtoolmodule.c
+@@ -675,8 +676,6 @@
+ return r;
+ }
+
+-#endif
+-
+ static char PyRRD_dump__doc__[] =
+ "dump - dump an RRD to XML\n"
+ "[--header|-h {none,xsd,dtd}] [--no-header]file.rrd [file.xml]";
+@@ -704,6 +703,7 @@
+ destroy_args(&argv);
+ return r;
+ }
++#endif /* HAVE_RRD_GRAPH */
+
+ /* List of methods defined in the module */
+ #define meth(name, func, doc) {name, (PyCFunction)func, METH_VARARGS, doc}
+@@ -717,14 +717,16 @@
+ meth("last", PyRRD_last, PyRRD_last__doc__),
+ meth("resize", PyRRD_resize, PyRRD_resize__doc__),
+ meth("info", PyRRD_info, PyRRD_info__doc__),
+-#ifdef HAVE_RRD_GRAPH
++#ifdef HAVE_RRD_GRAPH
+ meth("graph", PyRRD_graph, PyRRD_graph__doc__),
+ meth("graphv", PyRRD_graphv, PyRRD_graphv__doc__),
+ meth("xport", PyRRD_xport, PyRRD_xport__doc__),
+-#endif
++#endif /* HAVE_RRD_GRAPH */
+ meth("updatev", PyRRD_updatev, PyRRD_updatev__doc__),
+ meth("flushcached", PyRRD_flushcached, PyRRD_flushcached__doc__),
++#ifdef HAVE_RRD_GRAPH
+ meth("dump", PyRRD_dump, PyRRD_dump__doc__),
++#endif /* HAVE_RRD_GRAPH */
+ {NULL, NULL, 0, NULL}
+ };
+
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.5.5-rpn1.output b/net-analyzer/rrdtool/files/rrdtool-1.5.5-rpn1.output
new file mode 100644
index 000000000000..4a7696dbcf0b
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.5.5-rpn1.output
@@ -0,0 +1,3 @@
+print[0] = "30.769231"
+print[1] = "72.000000"
+print[2] = "0.000000"
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.5.5-rrdrados.pod b/net-analyzer/rrdtool/files/rrdtool-1.5.5-rrdrados.pod
new file mode 100644
index 000000000000..0c645548a202
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.5.5-rrdrados.pod
@@ -0,0 +1,68 @@
+=head1 NAME
+
+rrdrados - Creating, updating and retrieving RRD files from Ceph
+
+=head1 SYNOPSIS
+
+E<lt>rrdfileE<gt> = B<ceph//E<lt>nameE<gt>>
+
+
+=head1 DESCRIPTION
+
+This module adds support for creating, updating and retrieving RRD files
+directly from a Ceph cluster using librados.
+
+It adds a ceph// prefix to RRD file name which is used to instruct rrdtool to
+operate on a file that is stored in Ceph.
+
+Currently the module expects to find the Ceph configuration file in the default
+location at /etc/ceph/ceph.conf. By default it uses Ceph client ID "admin" and a
+Ceph pool named "rrd".
+
+
+=head1 ENVIRONMENT VARIABLES
+
+=over 4
+
+=item B<CEPH_ID>
+
+Sets the Ceph Client ID to use when connecting. By default the client ID "admin"
+is used.
+
+=item B<CEPH_POOL>
+
+Sets the name of the Ceph Pool to connect to. By default, the pool "rrd" is
+used.
+
+=back
+
+
+=head1 EXAMPLES
+
+B<Creating an RRD file on Ceph>
+
+ rrdtool create ceph//temperature.rrd --step 300 \
+ DS:temp:GAUGE:600:-273:5000 \
+ RRA:AVERAGE:0.5:1:1200 \
+ RRA:MIN:0.5:12:2400 \
+ RRA:MAX:0.5:12:2400 \
+ RRA:AVERAGE:0.5:12:2400
+
+
+B<Importing an existing RRD into Ceph>
+
+ rrdtool dump existing.rrd | rrdtool restore - ceph//new.rrd
+
+Or you could also copy the RRD file directly into Ceph using the rados command
+line utility.
+
+
+B<Retrieving RRD data from Ceph>
+
+ rrdtool fetch ceph//file.rrd AVERAGE
+
+
+=head1 AUTHOR
+
+Simon Boulet E<lt>simon@nostalgeek.comE<gt>
+
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.6.0-configure.ac.patch b/net-analyzer/rrdtool/files/rrdtool-1.6.0-configure.ac.patch
new file mode 100644
index 000000000000..a0bee695b7ae
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.6.0-configure.ac.patch
@@ -0,0 +1,25 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -177,7 +177,7 @@
+ AC_PROG_CPP
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+-AC_PROG_LIBTOOL
++LT_INIT
+
+ dnl Try to detect/use GNU features
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
+@@ -239,13 +239,6 @@
+ AC_CHECK_FUNC(acos, , AC_CHECK_LIB(m, acos))
+ AC_CHECK_FUNC(round, , AC_CHECK_LIB(m, round))
+
+-
+-
+-dnl add pic flag in any case this makes sure all our code is relocatable
+-eval `./libtool --config | grep pic_flag=`
+-CFLAGS="$CFLAGS $pic_flag"
+-
+-
+ dnl Checks for library functions.
+ AC_FUNC_STRFTIME
+ AC_FUNC_VPRINTF
diff --git a/net-analyzer/rrdtool/files/rrdtool-1.7.0-disable-rrd_graph-cgi.patch b/net-analyzer/rrdtool/files/rrdtool-1.7.0-disable-rrd_graph-cgi.patch
new file mode 100644
index 000000000000..beb1ba794f22
--- /dev/null
+++ b/net-analyzer/rrdtool/files/rrdtool-1.7.0-disable-rrd_graph-cgi.patch
@@ -0,0 +1,49 @@
+--- a/src/rrd_cgi.c
++++ b/src/rrd_cgi.c
+@@ -51,6 +51,7 @@
+ const char **);
+
+ /* call rrd_graph and insert appropriate image tag */
++#ifdef HAVE_RRD_GRAPH
+ static char *drawgraph(
+ long,
+ const char **);
+@@ -59,6 +60,7 @@
+ static char *drawprint(
+ long,
+ const char **);
++#endif /* HAVE_RRD_GRAPH */
+
+ /* pretty-print the <last></last> value for some.rrd via strftime() */
+ static char *printtimelast(
+@@ -510,9 +512,13 @@
+ }
+ parse(&buffer, i, "<RRD::GETVAR", rrdgetvar);
+ parse(&buffer, i, "<RRD::GOODFOR", rrdgoodfor);
++#ifdef HAVE_RRD_GRAPH
+ parse(&buffer, i, "<RRD::GRAPH", drawgraph);
++#endif /* HAVE_RRD_GRAPH */
+ parse(&buffer, i, "<RRD::INCLUDE", includefile);
++#ifdef HAVE_RRD_GRAPH
+ parse(&buffer, i, "<RRD::PRINT", drawprint);
++#endif /* HAVE_RRD_GRAPH */
+ parse(&buffer, i, "<RRD::SETCONSTVAR", rrdsetvarconst);
+ parse(&buffer, i, "<RRD::SETENV", rrdsetenv);
+ parse(&buffer, i, "<RRD::SETVAR", rrdsetvar);
+@@ -900,7 +906,7 @@
+ }
+
+
+-
++#ifdef HAVE_RRD_GRAPH
+ static char *drawgraph(
+ long argc,
+ const char **args)
+@@ -931,6 +937,7 @@
+ }
+ return NULL;
+ }
++#endif /* HAVE_RRD_GRAPH */
+
+ static char *drawprint(
+ long argc,