summaryrefslogtreecommitdiff
path: root/net-analyzer/python-gvm/python-gvm-23.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
commit0eb9883b5a8a53c253c98d1c77438c39c27c8c97 (patch)
tree47a89f252688f21fcacd066ac01ed1992a453d42 /net-analyzer/python-gvm/python-gvm-23.5.1.ebuild
parentc6872c361190d4f1a559d23458f6cdffb154b0b0 (diff)
gentoo auto-resync : 03:07:2023 - 10:05:34
Diffstat (limited to 'net-analyzer/python-gvm/python-gvm-23.5.1.ebuild')
-rw-r--r--net-analyzer/python-gvm/python-gvm-23.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/python-gvm-23.5.1.ebuild b/net-analyzer/python-gvm/python-gvm-23.5.1.ebuild
new file mode 100644
index 000000000000..22a851ada380
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-23.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/python-gvm/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # drop connection tests
+ rm -r tests/connections || die
+}