summaryrefslogtreecommitdiff
path: root/net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild')
-rw-r--r--net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild b/net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild
deleted file mode 100644
index 7a79e5d51e9a..000000000000
--- a/net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit depend.apache eutils
-
-DESCRIPTION="A performance data analyzer for nagios"
-HOMEPAGE="http://www.pnp4nagios.org"
-SRC_URI="mirror://sourceforge/${PN}/PNP-0.6/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
-
-DEPEND="
- dev-lang/php[json,simplexml,zlib,xml,filter]
- >=dev-lang/php-5.3
- >=net-analyzer/rrdtool-1.2[graph,perl]
- || ( net-analyzer/nagios-core net-analyzer/icinga net-analyzer/icinga2 )"
-RDEPEND="${DEPEND}
- virtual/perl-Getopt-Long
- virtual/perl-Time-HiRes
- media-fonts/dejavu
- apache2? ( www-servers/apache[apache2_modules_rewrite] )"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.6.14-makefile.patch
-}
-
-src_configure() {
- local var_dir=
- local user_group=
-
- if has_version net-analyzer/nagios-core; then
- var_dir=/var/nagios/
- user_group=nagios
- else
- var_dir=/var/lib/icinga/
- user_group=icinga
- fi
-
- econf \
- --sysconfdir=/etc/pnp \
- --datarootdir=/usr/share/pnp \
- --mandir=/usr/share/man \
- --with-perfdata-dir=${var_dir}/perfdata \
- --with-nagios-user=${user_group} \
- --with-nagios-group=${user_group} \
- --with-perfdata-logfile=${var_dir}/perfdata.log \
- --with-perfdata-spool-dir=/var/spool/pnp
-}
-
-src_compile() {
- # The default target just shows a help
- emake all
-}
-
-src_install() {
- emake DESTDIR="${D}" install install-config
- newinitd "${FILESDIR}"/npcd.initd npcd
- rm "${D}"/usr/share/pnp/install.php || die
-
- if use apache2 ; then
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${FILESDIR}"/98_pnp4nagios.conf
- fi
-
- # Bug 430358 - CVE-2012-3457
- find "${D}/etc/pnp" -type f -exec chmod 0640 {} \; || die
- find "${D}/etc/pnp" -type d -exec chmod 0750 {} \; || die
-}
-
-pkg_postinst() {
- elog "Please make sure to enable URL rewriting in Apache or any other"
- elog "webserver you're using, to get pnp4nagios running!"
-}