summaryrefslogtreecommitdiff
path: root/net-analyzer/pktstat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/pktstat/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/pktstat/files')
-rw-r--r--net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch46
-rw-r--r--net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch10
2 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch b/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch
new file mode 100644
index 000000000000..67ea9e9181e8
--- /dev/null
+++ b/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch
@@ -0,0 +1,46 @@
+--- a/tcp_smtp.c
++++ b/tcp_smtp.c
+@@ -149,13 +149,9 @@
+ struct smtp_state *state;
+ const char *s;
+ int addr_changed = 0;
+-FILE*log;
+
+ state = (struct smtp_state *)f->udata;
+
+-if ((log = fopen("/tmp/smtp.log", "a")))
+- fprintf(log, "smpt_line [%s]\n", line);
+-
+ if (state->in_data) {
+ if (strcmp(line, ".") == 0) {
+ state->in_data = 0;
+@@ -180,18 +176,15 @@
+ } else {
+ /* Normalize the command line */
+ normalize_line(line);
+-if (log)fprintf(log, "normalized to [%s]\n", line);
+ if ((s = strip_prefix(line, "MAIL FROM:"))) {
+ snprintf(state->from_addr, sizeof state->from_addr, "%s", s);
+ normalize_addr(state->from_addr);
+ addr_changed = 1;
+-if (log)fprintf(log, "from_addr = [%s]\n", state->from_addr);
+ }
+ else if ((s = strip_prefix(line, "RCPT TO:"))) {
+ snprintf(state->to_addr, sizeof state->to_addr, "%s", s);
+ normalize_addr(state->to_addr);
+ addr_changed = 1;
+-if (log)fprintf(log, "to_addr = [%s]\n", state->to_addr);
+ }
+ else if (strcmp(line, "DATA") == 0) {
+ state->in_data = 1;
+@@ -213,10 +206,7 @@
+ if (strcmp(line, "QUIT") != 0)
+ snprintf(f->desc, sizeof f->desc, "%s", line);
+ }
+-if (log)fprintf(log, "set desc to: [%s]\n", f->desc);
+ }
+-
+-if (log)fclose(log);
+ }
+
+ /*
diff --git a/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch b/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch
new file mode 100644
index 000000000000..5181124b8053
--- /dev/null
+++ b/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,6 +18,7 @@
+ AC_SEARCH_LIBS(gethostbyname, [nsl]) dnl for Solaris
+ AC_SEARCH_LIBS(pcap_open_live, [pcap])
+ AC_SEARCH_LIBS(exp, [m])
++PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",AC_MSG_ERROR[ncurses is required])
+ AC_SEARCH_LIBS(tgoto, [termlib termcap curses ncurses ocurses])
+ AC_SEARCH_LIBS(initscr, [curses ncurses ocurses])
+ AC_SEARCH_LIBS(nanosleep, [posix4])