summaryrefslogtreecommitdiff
path: root/net-analyzer/packit/packit-1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-analyzer/packit/packit-1.8.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-analyzer/packit/packit-1.8.ebuild')
-rw-r--r--net-analyzer/packit/packit-1.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/packit/packit-1.8.ebuild b/net-analyzer/packit/packit-1.8.ebuild
new file mode 100644
index 000000000000..77ed5d2691ae
--- /dev/null
+++ b/net-analyzer/packit/packit-1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Network packet generator and capture tool"
+HOMEPAGE="https://github.com/resurrecting-open-source-projects/packit"
+SRC_URI="https://github.com/resurrecting-open-source-projects/packit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="net-libs/libnet:1.1
+ net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc docs/*
+}