summaryrefslogtreecommitdiff
path: root/net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild')
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild
new file mode 100644
index 000000000000..34432cdfd0dd
--- /dev/null
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.105.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="the OpenBSD network swiss army knife"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/nc/"
+SRC_URI="http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz
+ http://http.debian.net/debian/pool/main/n/netcat-openbsd/netcat-openbsd_${PV}-7.debian.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x64-macos"
+
+DEPEND="virtual/pkgconfig"
+RDEPEND="dev-libs/libbsd"
+
+S=${WORKDIR}/netcat-openbsd-${PV}
+
+PATCHES=( "${WORKDIR}/debian/patches" )
+
+src_install() {
+ # avoid name conflict against net-analyzer/netcat
+ newbin nc nc.openbsd
+ newman nc.1 nc.openbsd.1
+ cd "${WORKDIR}/debian"
+ newdoc netcat-openbsd.README.Debian README
+ dodoc -r examples
+}
+
+pkg_postinst() {
+ if [[ ${KERNEL} = "linux" ]]; then
+ ewarn "FO_REUSEPORT is introduced in linux 3.9. If your running kernel is older"
+ ewarn "and kernel header is newer, nc will not listen correctly. Matching the header"
+ ewarn "to the running kernel will do. See bug #490246 for details."
+ fi
+}