summaryrefslogtreecommitdiff
path: root/net-analyzer/nttcp/nttcp-1.47-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/nttcp/nttcp-1.47-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/nttcp/nttcp-1.47-r3.ebuild')
-rw-r--r--net-analyzer/nttcp/nttcp-1.47-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/nttcp/nttcp-1.47-r3.ebuild b/net-analyzer/nttcp/nttcp-1.47-r3.ebuild
new file mode 100644
index 000000000000..f502164771a3
--- /dev/null
+++ b/net-analyzer/nttcp/nttcp-1.47-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="tool to test TCP and UDP throughput"
+HOMEPAGE="http://www.leo.org/~elmar/nttcp/"
+SRC_URI="http://www.leo.org/~elmar/nttcp/${P}.tar.gz"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}
+
+src_compile() {
+ emake \
+ ARCH= \
+ CC="$(tc-getCC)" \
+ LFLAGS="${LDFLAGS}" \
+ OPT="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}