summaryrefslogtreecommitdiff
path: root/net-analyzer/ntop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/ntop/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/ntop/files')
-rw-r--r--net-analyzer/ntop/files/ntop-5.0.1-INCS.patch27
-rw-r--r--net-analyzer/ntop/files/ntop-5.0.1-gentoo.patch240
-rw-r--r--net-analyzer/ntop/files/ntop-5.0.1-includes.patch20
-rw-r--r--net-analyzer/ntop/files/ntop-5.0.1-librrd.patch31
-rw-r--r--net-analyzer/ntop/files/ntop-confd9
-rw-r--r--net-analyzer/ntop/files/ntop-initd30
-rw-r--r--net-analyzer/ntop/files/ntop-initd-r124
-rw-r--r--net-analyzer/ntop/files/ntop-update-geoip-db21
8 files changed, 402 insertions, 0 deletions
diff --git a/net-analyzer/ntop/files/ntop-5.0.1-INCS.patch b/net-analyzer/ntop/files/ntop-5.0.1-INCS.patch
new file mode 100644
index 000000000000..de49a41d7175
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-5.0.1-INCS.patch
@@ -0,0 +1,27 @@
+--- a/configure
++++ b/configure
+@@ -18983,7 +18983,7 @@
+ else
+ LIBS="${LIBS} ${PYTHON_LIBS}"
+
+- PYTHON_INCS=`$PYTHON_CONFIG --cflags | sed -e "s/-arch i386//" | sed -e "s/-arch ppc//" | sed -e "s/-arch x86_64//"`
++ PYTHON_INCS=`$PYTHON_CONFIG --includes | sed -e "s/-arch i386//" | sed -e "s/-arch ppc//" | sed -e "s/-arch x86_64//"`
+
+ INCS="${INCS} ${PYTHON_INCS}"
+
+@@ -19335,15 +19335,6 @@
+ for(i=NF; i>0; i--) { \
+ if ($i in fields) { } else { fields[$i]="."; out[i]=$i } \
+ } \
+- for(i=1; i<=NF; i++) { \
+- if (i in out) { printf("%s ", out[i]) } \
+- } \
+- print "" \
+- }'`
+- INCS=`echo ${INCS} | ${ac_cv_prog_AWK} '{ \
+- for(i=NF; i>0; i--) { \
+- if ($i in fields) { } else { fields[$i]="."; out[i]=$i } \
+- } \
+ for(i=1; i<=NF; i++) { \
+ if (i in out) { printf("%s ", out[i]) } \
+ } \
diff --git a/net-analyzer/ntop/files/ntop-5.0.1-gentoo.patch b/net-analyzer/ntop/files/ntop-5.0.1-gentoo.patch
new file mode 100644
index 000000000000..57f136971cfc
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-5.0.1-gentoo.patch
@@ -0,0 +1,240 @@
+--- a/configure.in
++++ b/configure.in
+@@ -469,11 +469,6 @@
+ LOCALEDIR="/usr/lib/locale"
+ fi
+
+-dnl> Add /usr/local/ /opt/local
+-CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
+-CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
+-LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
+-
+ PWD=`pwd`
+
+ echo
+@@ -1739,18 +1734,6 @@
+ if test ".${ac_cv_lib_GeoIP_GeoIP_record_by_ipnum}" = ".yes"; then
+ LIBS="$LIBS -lGeoIP"
+
+-if test -f "GeoLiteCity.dat"; then
+- echo "GeoLiteCity.dat already present"
+-else
+- if test -f "3rd_party/GeoLiteCity.dat.gz"; then
+- cp 3rd_party/GeoLiteCity.dat.gz .
+- else
+- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+- fi
+-
+- gunzip GeoLiteCity.dat.gz
+-fi
+-
+ dnl> --------
+
+ if test -f "GeoIPASNum.dat"; then
+@@ -1769,8 +1752,11 @@
+ exit 1
+ fi
+
+-cp "3rd_party/oui.txt.gz" .
+-cp "3rd_party/specialMAC.txt.gz" .
++gunzip 3rd_party/GeoLiteCity.dat.gz &&
++mv "3rd_party/etter.finger.os.gz" . &&
++mv "3rd_party/oui.txt.gz" . &&
++mv "3rd_party/specialMAC.txt.gz" . ||
++ exit 1
+
+ if test -d ./configureextra; then
+
+@@ -1931,7 +1917,6 @@
+ AC_SUBST(SO_VERSION_PATCH)
+ AC_SUBST(RRD_LIB)
+ AC_SUBST(RRD_INC)
+-AC_SUBST(GEO_DIR)
+ AC_SUBST(GETOPT_H)
+ AC_SUBST(GETOPT_C)
+ AC_SUBST(NDPI_LIB)
+--- a/globals-core.c
++++ b/globals-core.c
+@@ -369,7 +369,7 @@
+ _mtuSize[DLT_ATM_RFC1483] = 9180 /* LLC/SNAP encapsulated atm */;
+ _headerSize[DLT_ATM_RFC1483] = 0;
+
+- /* _mtuSize[DLT_RAW] = ? raw IP */
++ _mtuSize[DLT_RAW] = 1500; /* raw IP */
+ _headerSize[DLT_RAW] = 0;
+
+ /* Others defined in bpf.h at tcpdump.org as of the resync - it would be NICE
+@@ -470,19 +470,18 @@
+ struct stat statbuf;
+
+ /* Initialize GeoIP databases */
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded config file %s", path);
+- break;
+ }
+ }
+ }
+@@ -491,20 +490,18 @@
+ traceEvent(CONST_TRACE_ERROR, "GeoIP: unable to load file %s", GEO_IP_FILE);
+
+ /* *************************** */
+-
+- for(i=0; myGlobals.configFileDirs[i] != NULL; i++) {
++ {
+ char path[256];
+
+ safe_snprintf(__FILE__, __LINE__, path, sizeof(path),
+ "%s%c%s",
+- myGlobals.configFileDirs[i],
++ myGlobals.dbPath,
+ CONST_PATH_SEP, GEO_IP_ASN_FILE);
+ revertSlashIfWIN32(path, 0);
+
+ if(stat(path, &statbuf) == 0) {
+ if((myGlobals.geo_ip_asn_db = GeoIP_open(path, GEOIP_CHECK_CACHE)) != NULL) {
+ traceEvent(CONST_TRACE_INFO, "GeoIP: loaded ASN config file %s", path);
+- break;
+ }
+ }
+ }
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -36,7 +36,6 @@
+
+ #AM_CFLAGS =
+ #AM_LDFLAGS=
+-ACLOCAL_AMFLAGS=-I m4
+
+ DISTCLEANFILES = trivialcompilemessage *.db #* *~ *.log
+ CLEANFILES = $(DISTCLEANFILES) stamp-h1
+@@ -67,9 +66,7 @@
+ NTOPDATA = ntop-cert.pem \
+ $(ETTER_PASSIVE) \
+ oui.txt.gz \
+- specialMAC.txt.gz \
+- GeoIPASNum.dat \
+- GeoLiteCity.dat
++ specialMAC.txt.gz
+
+ NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
+ html/*.css html/*.dtd \
+@@ -133,7 +130,7 @@
+
+ libntop_la_DEPENDENCIES = config.h
+ libntop_la_LIBADD = $(BASE_LIBS)
+-libntop_la_LDFLAGS = $(AM_LDFLAGS) -release $(VERSION) -export-dynamic @DYN_FLAGS@
++libntop_la_LDFLAGS = $(AM_LDFLAGS) -release $(VERSION) -export-dynamic -shared @DYN_FLAGS@
+
+ # Archive for http representation, or the 'viewer'
+ libntopreport_la_SOURCES = emitter.c globals-report.c graph.c \
+@@ -145,7 +142,7 @@
+
+ libntopreport_la_DEPENDENCIES = libntop.la
+ libntopreport_la_LIBADD = libntop.la $(BASE_LIBS)
+-libntopreport_la_LDFLAGS = $(AM_LDFLAGS) -release $(VERSION) -export-dynamic @DYN_FLAGS@
++libntopreport_la_LDFLAGS = $(AM_LDFLAGS) -release $(VERSION) -export-dynamic -shared @DYN_FLAGS@
+
+ man_MANS = ntop.8
+
+@@ -367,30 +364,7 @@
+
+ # download the vendor information table
+ dnvt:
+- @echo ""
+- @echo ""
+- @echo -n "Preparing "
+- @if test -f oui.txt; then \
+- rm -rf oui.txt; \
+- fi
+- @if test -f oui.txt.gz.old; then \
+- rm -rf oui.txt.gz.old; \
+- fi;
+- @mv oui.txt.gz oui.txt.gz.old
+- @echo "(old oui.txt.gz file is now oui.txt.gz.old)"
+- @echo ""
+- @wget -c http://standards.ieee.org/regauth/oui/oui.txt
+- @gzip oui.txt
+- @echo ""
+- @echo ""
+- @echo -n "Old file lines were: "
+- @gunzip -c oui.txt.gz.old | wc -l
+- @echo -n "New file lines are: "
+- @gunzip -c oui.txt.gz | wc -l
+- @echo ""
+- @echo ""
+- @echo "New file is:"
+- @ls -l oui.txt.gz
++ @echo "Use included oui.txt.gz"
+
+ # download the Novell SAP Protocol information table
+ #dnsapt:
+@@ -398,45 +372,7 @@
+
+ # download the passive ethernet fingerprint database
+ dnetter:
+- @echo ""
+- @echo ""
+- @echo "Preparing "
+- @echo ""
+-
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo "...Deleting prior file, $(ETTER_PASSIVE).old..."; \
+- rm -rf $(ETTER_PASSIVE).old; \
+- fi;
+- @if test -f $(ETTER_PASSIVE); then \
+- echo "...Moving current $(ETTER_PASSIVE) to $(ETTER_PASSIVE).old"; \
+- mv $(ETTER_PASSIVE) $(ETTER_PASSIVE).old; \
+- fi;
+- @for file in $(ETTER_PASSIVE) $(ETTER_PASSIVE).gz \
+- $(ETTER_PASSIVE_FILE) $(ETTER_PASSIVE_FILE).gz; do \
+- if test -f $$file; then \
+- echo "...Deleting prior file, $$file..."; \
+- rm -rf $$file; \
+- fi; \
+- done
+- @echo ""
+- @echo "...Downloading new file..."
+- @wget -O $(ETTER_PASSIVE_FILE) \
+- $(ETTER_PASSIVE_DOWNLOAD_FROM)/$(ETTER_PASSIVE_FILE)?$(ETTER_PASSIVE_DOWNLOAD_PARMS)
+- @echo ""
+- @echo "gziping downloaded file..."
+- @gzip $(ETTER_PASSIVE_FILE)
+- @echo ""
+- @echo ""
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo -n "Old file lines were: "; \
+- gunzip -c $(ETTER_PASSIVE).old | wc -l; \
+- fi;
+- @echo -n "New file lines are: "
+- @gunzip -c $(ETTER_PASSIVE) | wc -l
+- @echo ""
+- @echo ""
+- @echo "New file is:"
+- @ls -l $(ETTER_PASSIVE)
++ @echo "Use included $(ETTER_PASSIVE)"
+
+ # ntop census
+ census-fail:
+--- a/report.c
++++ b/report.c
+@@ -2299,7 +2299,7 @@
+ if(fetchPrefsValue("dot.path", buf, sizeof(buf)) != -1) {
+ snprintf(dotPath, sizeof(dotPath), "%s", buf);
+ } else {
+- snprintf(dotPath, sizeof(dotPath), "/usr/local/bin/dot");
++ snprintf(dotPath, sizeof(dotPath), "/usr/bin/dot");
+ storePrefsValue("dot.path", dotPath); /* Set the default */
+ }
+
diff --git a/net-analyzer/ntop/files/ntop-5.0.1-includes.patch b/net-analyzer/ntop/files/ntop-5.0.1-includes.patch
new file mode 100644
index 000000000000..fcd5f28d3491
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-5.0.1-includes.patch
@@ -0,0 +1,20 @@
+--- a/nDPI/src/lib/protocols/netflow.c
++++ b/nDPI/src/lib/protocols/netflow.c
+@@ -19,6 +19,7 @@
+
+
+ #include "ipq_utils.h"
++#include <time.h> /* time() */
+
+ #ifdef NTOP_PROTOCOL_NETFLOW
+
+--- a/nDPI/src/lib/protocols/ssl.c
++++ b/nDPI/src/lib/protocols/ssl.c
+@@ -22,6 +22,7 @@
+
+
+ #include "ipq_utils.h"
++#include <ctype.h> /* isalpha() isdigit() ... */
+
+ #ifdef IPOQUE_PROTOCOL_SSL
+
diff --git a/net-analyzer/ntop/files/ntop-5.0.1-librrd.patch b/net-analyzer/ntop/files/ntop-5.0.1-librrd.patch
new file mode 100644
index 000000000000..db2530c8a5e5
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-5.0.1-librrd.patch
@@ -0,0 +1,31 @@
+--- a/configure.in
++++ b/configure.in
+@@ -887,28 +887,6 @@
+ fi
+ fi
+
+-RRD_LIB="-L${RRD_HOME}/lib -lrrd_th"
+-
+-if test -f "$RRD_HOME/lib/librrd_th.so"; then
+- AC_MSG_RESULT(checking for rrdtool... yes)
+-else
+- if test -f "$RRD_HOME/lib/librrd_th.dylib"; then # OSX
+- AC_MSG_RESULT(checking for rrdtool... yes)
+- else
+- if test -f "$RRD_HOME/lib/librrd_th.a"; then
+- AC_MSG_RESULT(checking for rrdtool... yes)
+- else
+- AC_CHECK_LIB([rrd_th], [main])
+- if test ".${ac_cv_lib_rrd_th_main}" != ".yes"; then
+- AC_MSG_ERROR(Unable to find RRD at $RRD_HOME: please use --with-rrd-home=DIR);
+- AC_MSG_ERROR(RRD source can be downloaded from http://www.rrdtool.org/);
+- else
+- RRD_LIB=
+- fi
+- fi
+- fi
+-fi
+-
+ RRD_INC=
+ if test -d "${RRD_HOME}/include"; then
+ RRD_INC="-I${RRD_HOME}/include"
diff --git a/net-analyzer/ntop/files/ntop-confd b/net-analyzer/ntop/files/ntop-confd
new file mode 100644
index 000000000000..352a26fa9b1c
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-confd
@@ -0,0 +1,9 @@
+# Config file for /etc/init.d/ntop
+
+# Set preferred options here
+#NTOP_OPTS="--http-server 3000 --https-server 0 --interface eth0"
+
+# suggestions from bug #136983 (use it in case you experience ntop hangs)
+#NTOP_OPTS="u ntop -P /var/lib/ntop --disable-schedyield --http-server 3000 --https-server 3001"
+
+NTOP_OPTS="-u ntop -P /var/lib/ntop"
diff --git a/net-analyzer/ntop/files/ntop-initd b/net-analyzer/ntop/files/ntop-initd
new file mode 100644
index 000000000000..ec9afd576f32
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-initd
@@ -0,0 +1,30 @@
+#!/sbin/openrc-run
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /var/lib/ntop/ntop_pw.db ]; then
+ eerror "You need to set a password first by running"
+ eerror "ntop --set-admin-password"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ntop"
+ export LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+ export GDFONTPATH=/usr/share/fonts/corefonts # apparently the only font that works (#231705)
+ start-stop-daemon --start --exec /usr/bin/ntop -- -d -L ${NTOP_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ntop"
+ start-stop-daemon --stop --retry 30 --pidfile /var/run/ntop.pid
+ eend $?
+}
diff --git a/net-analyzer/ntop/files/ntop-initd-r1 b/net-analyzer/ntop/files/ntop-initd-r1
new file mode 100644
index 000000000000..e303753891e6
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-initd-r1
@@ -0,0 +1,24 @@
+#!/sbin/openrc-run
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="ntop - a network traffic analyzer"
+pidfile="/run/ntop.pid"
+command="/usr/bin/ntop"
+command_args="-L ${NTOP_OPTS}"
+start_stop_daemon_args="-p ${pidfile} -m -b"
+
+depend() {
+ need net
+}
+
+start_pre() {
+ if [ ! -e /var/lib/ntop/ntop_pw.db ] ; then
+ eerror "You need to set a password first by running"
+ eerror "ntop --set-admin-password"
+ return 1
+ fi
+
+ export LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+ export GDFONTPATH=/usr/share/fonts/corefonts # apparently the only font that works (#231705)
+}
diff --git a/net-analyzer/ntop/files/ntop-update-geoip-db b/net-analyzer/ntop/files/ntop-update-geoip-db
new file mode 100644
index 000000000000..2bf3faaf68cb
--- /dev/null
+++ b/net-analyzer/ntop/files/ntop-update-geoip-db
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+BASE_URL=http://geolite.maxmind.com/download/geoip/database
+
+echo "Updating NTOP GeoIP databases..."
+
+cd /var/lib/ntop || exit
+
+for u in asnum/GeoIPASNum.dat.gz GeoLiteCity.dat.gz ; do
+ FILE_GZ=${u#*/}
+ FILE=${FILE_GZ%.gz}
+ wget -nv -O ${FILE_GZ} ${BASE_URL}/${u} &&
+ gunzip < ${FILE_GZ} > .${FILE} &&
+ mv -f .${FILE} ${FILE} &&
+ rm -f ${FILE_GZ} ||
+ exit
+done
+
+/etc/init.d/ntop --quiet status && /etc/init.d/ntop restart
+
+echo "NTOP GeoIP databases were successfully updated"