summaryrefslogtreecommitdiff
path: root/net-analyzer/netselect/netselect-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-analyzer/netselect/netselect-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-analyzer/netselect/netselect-9999.ebuild')
-rw-r--r--net-analyzer/netselect/netselect-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/netselect/netselect-9999.ebuild b/net-analyzer/netselect/netselect-9999.ebuild
new file mode 100644
index 000000000000..de08fdebbdfa
--- /dev/null
+++ b/net-analyzer/netselect/netselect-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Ultrafast implementation of ping"
+HOMEPAGE="http://apenwarr.ca/netselect/"
+EGIT_REPO_URI="
+ https://github.com/apenwarr/${PN}
+"
+SRC_URI="
+ ipv6? ( https://dev.gentoo.org/~jer/${PN}-0.4-ipv6.patch.xz )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="ipv6"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4-bsd.patch
+ "${FILESDIR}"/${PN}-0.4-flags.patch
+)
+
+src_unpack() {
+ use ipv6 && unpack ${A}
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ use ipv6 && PATCHES+=( "${WORKDIR}"/${PN}-0.4-ipv6.patch )
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ dobin netselect
+
+ if ! use prefix ; then
+ fowners root:wheel /usr/bin/netselect
+ fperms 4711 /usr/bin/netselect
+ fi
+
+ dodoc HISTORY README
+
+ doman netselect.1
+}