summaryrefslogtreecommitdiff
path: root/net-analyzer/netio/netio-1.33.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-analyzer/netio/netio-1.33.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-analyzer/netio/netio-1.33.ebuild')
-rw-r--r--net-analyzer/netio/netio-1.33.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/netio/netio-1.33.ebuild b/net-analyzer/netio/netio-1.33.ebuild
new file mode 100644
index 000000000000..b1b367dca376
--- /dev/null
+++ b/net-analyzer/netio/netio-1.33.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit edos2unix toolchain-funcs
+
+DESCRIPTION="Network benchmark using TCP and UDP protocols"
+HOMEPAGE="https://web.ars.de/netio/"
+SRC_URI="https://www.ars.de/${PN}${PV/.}.zip"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+RESTRICT="mirror" # bug #391789 comment #1
+
+DEPEND="
+ app-arch/unzip
+ >=sys-apps/sed-4
+"
+S=${WORKDIR}
+
+src_prepare() {
+ edos2unix *.c *.h *.doc
+
+ default
+
+ sed -i \
+ -e "s|LFLAGS=\"\"|LFLAGS?=\"${LDFLAGS}\"|g" \
+ -e 's|\(CC\)=|\1?=|g' \
+ -e 's|\(CFLAGS\)=|\1+=|g' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ linux
+}
+
+src_install() {
+ dobin netio
+ dodoc netio.doc
+}