summaryrefslogtreecommitdiff
path: root/net-analyzer/nethogs/nethogs-0.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /net-analyzer/nethogs/nethogs-0.8.7.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'net-analyzer/nethogs/nethogs-0.8.7.ebuild')
-rw-r--r--net-analyzer/nethogs/nethogs-0.8.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/nethogs/nethogs-0.8.7.ebuild b/net-analyzer/nethogs/nethogs-0.8.7.ebuild
new file mode 100644
index 000000000000..67bfac5facf0
--- /dev/null
+++ b/net-analyzer/nethogs/nethogs-0.8.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps toolchain-funcs
+
+DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
+HOMEPAGE="https://github.com/raboof/nethogs"
+SRC_URI="https://github.com/raboof/nethogs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~x86"
+
+RDEPEND="net-libs/libpcap
+ sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( DESIGN README.decpcap.txt README.md )
+
+FILECAPS=(
+ cap_net_admin,cap_net_raw usr/sbin/nethogs
+)
+
+src_compile() {
+ tc-export CC CXX
+
+ emake NCURSES_LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )" ${PN}
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="/usr" install
+ einstalldocs
+}