summaryrefslogtreecommitdiff
path: root/net-analyzer/netdiscover/netdiscover-0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-analyzer/netdiscover/netdiscover-0.7.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-analyzer/netdiscover/netdiscover-0.7.ebuild')
-rw-r--r--net-analyzer/netdiscover/netdiscover-0.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/netdiscover/netdiscover-0.7.ebuild b/net-analyzer/netdiscover/netdiscover-0.7.ebuild
new file mode 100644
index 000000000000..08c7f4e6b20a
--- /dev/null
+++ b/net-analyzer/netdiscover/netdiscover-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="An active/passive address reconnaissance tool"
+HOMEPAGE="https://github.com/netdiscover-scanner/netdiscover"
+LICENSE="GPL-2"
+SRC_URI="
+ https://github.com/${PN}-scanner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="
+ >=net-libs/libpcap-0.8.3-r1
+"
+RDEPEND="
+ ${DEPEND}
+"
+S=${WORKDIR}/${P/_/-}
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}