summaryrefslogtreecommitdiff
path: root/net-analyzer/netdata/netdata-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /net-analyzer/netdata/netdata-9999.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'net-analyzer/netdata/netdata-9999.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 9e53cefcc74a..54d150969d3c 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit autotools fcaps linux-info python-r1 systemd user
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 ipmi mysql nfacct nodejs postgres +python tor"
+IUSE="caps +compression cpu_flags_x86_sse2 cups ipmi mysql nfacct nodejs postgres +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -27,10 +27,10 @@ REQUIRED_USE="
# most unconditional dependencies are for plugins.d/charts.d.plugin:
RDEPEND="
+ app-misc/jq
>=app-shells/bash-4:0
|| (
net-analyzer/openbsd-netcat
- net-analyzer/netcat6
net-analyzer/netcat
)
net-analyzer/tcpdump
@@ -40,6 +40,7 @@ RDEPEND="
sys-apps/util-linux
virtual/awk
caps? ( sys-libs/libcap )
+ cups? ( net-print/cups )
compression? ( sys-libs/zlib )
ipmi? ( sys-libs/freeipmi )
nfacct? (
@@ -58,6 +59,10 @@ RDEPEND="
)
postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
tor? ( net-libs/stem[${PYTHON_USEDEP}] )
+ )
+ xen? (
+ app-emulation/xen-tools
+ dev-libs/yajl
)"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -85,8 +90,10 @@ src_configure() {
econf \
--localstatedir="${EPREFIX}"/var \
--with-user=${NETDATA_USER} \
+ $(use_enable cups plugin-cups) \
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
+ $(use_enable xen plugin-xenstat) \
$(use_enable cpu_flags_x86_sse2 x86-sse) \
$(use_with compression zlib)
}