summaryrefslogtreecommitdiff
path: root/net-analyzer/netdata/netdata-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /net-analyzer/netdata/netdata-9999.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'net-analyzer/netdata/netdata-9999.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 8d23470a368d..9e53cefcc74a 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
inherit autotools fcaps linux-info python-r1 systemd user
@@ -19,10 +19,12 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 ipmi mysql nfacct nodejs postgres +python"
+IUSE="caps +compression cpu_flags_x86_sse2 ipmi mysql nfacct nodejs postgres +python tor"
REQUIRED_USE="
mysql? ( python )
- python? ( ${PYTHON_REQUIRED_USE} )"
+ python? ( ${PYTHON_REQUIRED_USE} )
+ tor? ( python )"
+
# most unconditional dependencies are for plugins.d/charts.d.plugin:
RDEPEND="
>=app-shells/bash-4:0
@@ -55,6 +57,7 @@ RDEPEND="
)
)
postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ tor? ( net-libs/stem[${PYTHON_USEDEP}] )
)"
DEPEND="${RDEPEND}
virtual/pkgconfig"