summaryrefslogtreecommitdiff
path: root/net-analyzer/net-snmp/net-snmp-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-analyzer/net-snmp/net-snmp-99999999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-analyzer/net-snmp/net-snmp-99999999.ebuild')
-rw-r--r--net-analyzer/net-snmp/net-snmp-99999999.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-99999999.ebuild b/net-analyzer/net-snmp/net-snmp-99999999.ebuild
index dd3818e50c1d..638e5357bb17 100644
--- a/net-analyzer/net-snmp/net-snmp-99999999.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-99999999.ebuild
@@ -2,13 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_SINGLE_IMPL=yesplz
DISTUTILS_OPTIONAL=yesplz
-WANT_AUTOMAKE=none
-PATCHSET=3
+DISTUTILS_SINGLE_IMPL=yesplz
GENTOO_DEPEND_ON_PERL=no
-
+PATCHSET=3
+PYTHON_COMPAT=( python3_{6,7,8} )
+WANT_AUTOMAKE=none
inherit autotools distutils-r1 git-r3 perl-module systemd
DESCRIPTION="Software for generating and retrieving SNMP data"
@@ -20,7 +19,7 @@ SRC_URI="
# GPL-2 for the init scripts
LICENSE="HPND BSD GPL-2"
-SLOT="0/35"
+SLOT="0/40"
KEYWORDS=""
IUSE="
X bzip2 doc elf kmem ipv6 libressl lm-sensors mfd-rewrites minimal mysql
@@ -69,14 +68,15 @@ RDEPEND="
)
selinux? ( sec-policy/selinux-snmp )
"
-S=${WORKDIR}/${P/_/.}
-S=${WORKDIR}/${P/_p*/}
RESTRICT=test
PATCHES=(
"${FILESDIR}"/${PN}-5.7.3-include-limits.patch
"${FILESDIR}"/${PN}-5.8-do-not-conflate-LDFLAGS-and-LIBS.patch
"${FILESDIR}"/${PN}-5.8-pcap.patch
"${FILESDIR}"/${PN}-5.8.1-pkg-config.patch
+ "${FILESDIR}"/${PN}-5.8.1-net-snmp-config-libdir.patch
+ "${FILESDIR}"/${PN}-5.8.1-mysqlclient.patch
+ "${FILESDIR}"/${PN}-5.9-MakeMaker.patch
"${FILESDIR}"/${PN}-99999999-tinfo.patch
)
@@ -130,7 +130,8 @@ src_configure() {
$(use_with ssl openssl) \
$(use_with tcpd libwrap) \
$(use_with zlib) \
- --enable-shared --disable-static \
+ --disable-static \
+ --enable-shared \
--with-default-snmp-version="3" \
--with-install-prefix="${D}" \
--with-ldflags="${LDFLAGS}" \
@@ -142,8 +143,11 @@ src_configure() {
}
src_compile() {
- for target in snmplib agent sedscript all; do
- emake OTHERLDFLAGS="${LDFLAGS}" ${target}
+ emake sedscript
+
+ local subdir
+ for subdir in snmplib agent/mibgroup agent apps .; do
+ emake OTHERLDFLAGS="${LDFLAGS}" -C ${subdir} all
done
use doc && emake docsdox