summaryrefslogtreecommitdiff
path: root/net-analyzer/nessus-bin/nessus-bin-10.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-07 15:42:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-07 15:42:35 +0100
commita693a49d235bea057923bcbc2ee6a40cce4bb060 (patch)
tree7b927ab3d5df3dce15e8c6a727db1831137f9a00 /net-analyzer/nessus-bin/nessus-bin-10.5.1.ebuild
parentbba809b22a050e394e6ce550572ee7f6c6e02a6e (diff)
gentoo auto-resync : 07:06:2023 - 15:42:35
Diffstat (limited to 'net-analyzer/nessus-bin/nessus-bin-10.5.1.ebuild')
-rw-r--r--net-analyzer/nessus-bin/nessus-bin-10.5.1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/net-analyzer/nessus-bin/nessus-bin-10.5.1.ebuild b/net-analyzer/nessus-bin/nessus-bin-10.5.1.ebuild
deleted file mode 100644
index a977f8ba6efb..000000000000
--- a/net-analyzer/nessus-bin/nessus-bin-10.5.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit rpm systemd
-
-MY_P="Nessus-${PV}-es8"
-
-DESCRIPTION="A remote security scanner for Linux"
-HOMEPAGE="https://www.tenable.com/"
-SRC_URI="
- amd64? ( https://www.tenable.com/downloads/api/v2/pages/${PN%-bin}/files/${MY_P}.x86_64.rpm )
- arm64? ( https://www.tenable.com/downloads/api/v2/pages/${PN%-bin}/files/${MY_P}.aarch64.rpm )
-"
-
-LICENSE="GPL-2 Tenable-Master-Agreement"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~arm64"
-
-RESTRICT="mirror strip"
-
-QA_PREBUILT="opt/nessus/bin/*
- opt/nessus/lib/nessus/*.so
- opt/nessus/lib/nessus/iconv/*.so
- opt/nessus/lib/nessus/libjemalloc.so.*
- opt/nessus/sbin/*"
-
-S="${WORKDIR}"
-
-src_install() {
- # Using doins -r would strip executable bits from all binaries
- cp -pPR "${S}"/opt "${D}"/ || die "Failed to copy files"
-
- # Make sure these originally empty directories do not vanish,
- # Nessus will not run properly without them
- keepdir /opt/nessus/com/nessus/CA
- keepdir /opt/nessus/etc/nessus
- keepdir /opt/nessus/var/nessus/logs
- keepdir /opt/nessus/var/nessus/tmp
-
- newinitd "${FILESDIR}"/nessusd-initd nessusd-bin
- systemd_newunit usr/lib/systemd/system/nessusd.service nessusd-bin.service
-}
-
-pkg_postinst() {
- # Actually update Nessus core components. According to upstream packages,
- # harmless to invoke on fresh installations too - and it may make life easier
- # for people who had restored Nessus state from backups, had it lying around
- # from older installations and so on.
- "${EROOT}"/opt/nessus/sbin/nessuscli install "${EROOT}"/opt/nessus/var/nessus/plugins-core.tar.gz
-
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog "To get started launch the nessusd-bin service, then point your Web browser to"
- elog " https://<yourhost>:8834/"
- else
- elog "Please restart the nessusd-bin service to use the new version of Nessus"
- fi
-}