summaryrefslogtreecommitdiff
path: root/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/multimon-ng/multimon-ng-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/multimon-ng/multimon-ng-9999.ebuild')
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-analyzer/multimon-ng/multimon-ng-9999.ebuild b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
new file mode 100644
index 000000000000..6ba3057182a6
--- /dev/null
+++ b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
+HOMEPAGE="https://github.com/EliasOenal/multimonNG"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="https://github.com/EliasOenal/multimonNG.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/multimonNG-${PV}
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pulseaudio"
+
+DEPEND="pulseaudio? ( media-sound/pulseaudio )
+ dev-qt/qtcore:4
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if use !pulseaudio; then
+ sed -i -e 's/-lpulse-simple//' -e 's/-lpulse//' -e 's/PULSE/DUMMY/' ${PN}.pro || die
+ fi
+ qt4-r2_src_prepare
+}
+src_install() {
+ dobin ${PN}
+}