summaryrefslogtreecommitdiff
path: root/net-analyzer/mtr/mtr-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /net-analyzer/mtr/mtr-9999.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'net-analyzer/mtr/mtr-9999.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
index 75a592ba00d8..3f821be8ee37 100644
--- a/net-analyzer/mtr/mtr-9999.ebuild
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools fcaps flag-o-matic git-r3
+inherit autotools bash-completion-r1 fcaps git-r3
DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
HOMEPAGE="https://www.bitwizard.nl/mtr/"
@@ -11,18 +11,20 @@ EGIT_REPO_URI="https://github.com/traviscross/mtr"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="gtk ipv6 ncurses"
+IUSE="+gtk +ipinfo +ipv6 +jansson +ncurses"
RDEPEND="
gtk? (
dev-libs/glib:2
x11-libs/gtk+:3
)
+ jansson? ( dev-libs/jansson )
ncurses? ( sys-libs/ncurses:0= )
"
DEPEND="
${RDEPEND}
- sys-devel/autoconf
+"
+BDEPEND="
virtual/pkgconfig
"
DOCS=( AUTHORS FORMATS NEWS README.md SECURITY TODO )
@@ -39,13 +41,13 @@ src_prepare() {
}
src_configure() {
- # In the source's configure script -lresolv is commented out. Apparently it
- # is still needed for 64-bit MacOS.
- [[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
econf \
$(use_enable ipv6) \
$(use_with gtk) \
- $(use_with ncurses)
+ $(use_with ipinfo) \
+ $(use_with jansson) \
+ $(use_with ncurses) \
+ --with-bashcompletiondir="$(get_bashcompdir)"
}
pkg_postinst() {